Inventables Community Forum

Carving Path Shifts on 4040-xe

Complete newbie here running 4040-xe. I like Easel because very simple setup and process, but all my projects are shifting after the first pass. I’m at a complete loss. The first pass was going good. Didn’t hit any limit switches, but just before finishing complete first pass, it stopped short, and then shifted left.


all of your settings seem fine on the easel side, but If you happened to have selected the X-Carve photo when you did the Machine Setup, then your $102 would have been set to the X-Carve one and this will result in extra deep carves, and then you’ll loose steps and your carve will jump like that…

Can you verify all of your Grbl Settings match these (scroll down to get to the 4040XE… this page has both Masuter and XE) Specifically the $102 and on.

That said, you’ll find a bunch of support and a ton of people highly familiar with your machine over on the Fox Alien Group on FaceBook.

That looks like you lost steps. The outline has moved to the left because at some point the machine tried to move to the right but it bogged down. The machine believes that it moved to the right as far as it was supposed to and simply continues where it is at.

Given that it looks like it suddenly shifted, I’m guessing that it stalled out due to debris in the tool path and then suddenly broke free. You might try some different bits, try shallower depth per pass, try slower feed rate or try to keep the tool path clean by getting in with a vacuum.

Then again, Texas has been known to change its borders. It dropped the northern border to be south of the Mason Dixon line which ultimately created the pan handle on Oklahoma.


These are current settings. Look to be same as defaults in the link

small cnc/ small production rate . try reducing the feed rate . if that doesn’t work , reduce the depth of cut.

Yeah what I have found out was the z axis/depth as the issue. I’m having issues with z probe setup feature. It’s just not working now. So had to manually set z axis and when I did, worked. That first pass was supposed be .6mm per pass, but ended up at 1.76 YIKES.