Carving Problems with Vcarve Desktop on Xcarve 1000mm

I just recently bought Vcarve Desktop and have been learning by using the trial version for a few weeks before buying and actually cutting something. I tried my first carve yesterday and it was a disaster. Within 5 seconds, I broke the 1/8" 3 flute upcut end mill I was using. I’m hoping I can get some help here so I don’t break the rest of the end mills that I have.

I created a star with the Vcarve software and wanted to cut it out in 7/8" Red Oak. I set up the work piece on my Xcarve and entered the machine home command in UGS 2.0 ($H) and it worked without a problem. I then I set up the work piece home (G92 X0 Y0 Z0). Then I sent the carve to the machine. The spindle moved and I thought it was going to where it was supposed to but it started at the 1/8" depth that was set up in the wrong place, moved to where it was supposed to start cutting and plunged in 1/2" and then squiggled for a couple of seconds before the bit broke. I’ll post pictures of all of my settings and maybe something will stand out as to where I went wrong and I can get some advice on how to fix my problem. Thank you in advance and I apologize for the long post!

For a 1/8" bit, you should set a depth of cut of 1/16" or less. You feed rate of 100ipm is way too fast, especially for oak. Did your bit come loosed from the collet?

No. The bit didn’t come loose. It just snapped off. I used the default settings in Vcarve for the speed and feed rate as well as the depth of cut. I will change that for the next attempt. But what caused the plunge down to 1/2"? It cut like that for an inch or so before it broke.

Try to not have your depth of cut greater than half of your diameter of your cutter. As for your speed start slow and figure out what your machine can handle.

If I remember correctly, even tho you may be working in inches in vcarve, setup your post processor as the mm xcarve. The. In chilipeppr also make sure everything is mm. I had some wackiness between trying to use chilipeppr to translate. Deep plunges and the like…

Even using UGS 2.0 choose the Postp xcarve mm rather than the xcarve inches?

Why choose the mm post processor? I use the inches one in both UGS and Chilipeppr with no issues.

Why would you use two different measurement systems? I work with inches in VCarve, use inches in my PP and the gcode works out fine. The main precaution is to check whatever PP you use to be sure it issues a G20 command at the beginning so it sets your controller to work in inches.

1 Like

I don’t remember the details now… Think the version of ugs defaulted to mm, and I think you are right about the g20 command being the fix. I just wanted to align to defaults, and it didn’t matter post vcarve what gcode was measured in…

I don’t know anything about V-Carve, but I did just finish cutting a lot of stuff out of red oak. In my opinion, red oak SUCKS to mill because there’s such a difference between cutting across the grain and with the grain. If you are spinning too fast or moving too slow, it’s super-easy to blue the bit and ruin it. If you go too deep or move too slow, it’s super-easy to break the bit.

I used the 2 straight flute flat endmill, and wouldn’t recommend anything with more than 2 flutes. I had my Dewalt 611 turned all the way down to ‘1’, and still had to worry about it spinning too fast. I cut .060" deep passes at 50 IPM. Maybe that’ll help you at least get a better feed/speed set up in your machine.


I remember a bit more. I did have some trouble when I first started with aspire and ugs, and finally got it straight. Then some beta version came out that had a bug in the homing system. If you made a cut in inches, then soft reset, then homed, the homing routine used steps as if you were in mm even tho the system still thought it was in inches. The result is the thing flew across the y axis and slammed into the rail really fast… The work around in the forums was to go back to mm after each cut and let your gcode set back to inches the next time… I just thought why fight this if it didn’t matter what the gcode was in…

Although I work in inches, I’ve left UGS at its default of reporting in mm. If it bothers you to see mm in UGS, you can set $13=1 to change UGS to report in inches. I’ve read about this but haven’t done it on my system - yet. Gotta see if I like it.

Mine is set to report in inches. Works fine.

I am running v-carve desk top I import into easel and used the v-carve pro processor and set it up their it seems to work fine

Well, some progress but not much. I ruined another piece of Oak but this time I was able to get the carve stopped before I broke another bit. I took the recommendations that have been posted regarding the speed, feed rate and depth being too aggressive and made changes to reflect the following. Speed 12000 RPM, Feed Rate 30 in/min, Plunge rate 15 in/min, depth of cut .035 inches (25 passes). I homed the machine and then homed the work piece. Sent the gcode to the machine and it started cutting at a depth of 1/4"!!. I have Vcarve desktop version 8 and it has the xcarve Postp inches and the G20 command is already in the code. I’m at a complete loss!

hey robert have you experienced differences in speeds as far as red and white oak go?

I haven’t played with white oak yet, but I imagine they’re probably pretty similar. I want to make a smaller version of the jewelry holders out of some though, when I find the time.

crazy I really have been cutting everything on notch 6 on the dewalt and no problems with any material even plastics and foam

I have cut
red/white oak
tempered hardboard

all at the same setting I am just curious if i am missing something lol

In general, there’s very little material that you can effectively cut at the high 611 speeds without burning or dulling your bits. Additionally, the faster you run it the sooner you’ll wear out the brushes and either have to replace them or replace the 611.

The DWP611 is designed for handheld routing in all types of material. If using it handheld, one would normally use the highest speed for the smallest bits that would typically be 2-flute (chamfer, roundover, etc.). However, having one mounted on my SO2, I keep the speed setting at 3-4 because I find that fast enough for what I do.