Carving unprecise shapes (problem with the x-axis maybe)


Soo I just finished assembling my fully loaded x-carve a few days ago, and have already run quite a few tests. I am having a big issue, my machine cuts some very uneven shapes, however always the same. Then I first noticed it was then I was cutting out a heart, it simply looked terrible, I tried adjusting the pots on g-shield, however without any luck. I did a few tests with a pencil and I have been trying to draw all kind of shapes, and all shapes gets a little uneven. Worst are the circles, I have attached a picture.

Does anyone know have I am to fix this problem, it really frustrates me. I have double-checked all the wheels and tightened all the rails… Even did a few live tests drawing circles while adjusting the pots, with no visible change. However if I look at the x-axis’ stepper motor while running then it comes to the “uneveness” it kind of makes a bumb or something.

Any help would be much appreciated. Thanks!

That looks like you machine isn’t going far enough in the Y direction. Make sure your v-wheels aren’t too tight (I had this problems). Also check that your pulleys aren’t slipping on the motor shafts.

Hopefully you can get it sorted! I’ve had my machine for a couple months now and I’m still trying to get it sorted, some days are great other not so much, but that’s the game!

Hi Rusty, thanks for your answer. I have tried unbelting the y-axis, so I freely could move the x-axis along the y-axis. It runs smooth, with only little tension (all v-whells are turning). The pulleys aren’t slipping on the motor shafts, I have tightened them all very carefully. Its seems to me that a mechanical problem would be very unlikely, because it repeats the same pattern over and over again. Doing the same mistake every time. Or am I wrong? :blush:

That is strange. Maybe check all your wiring, make sure all the wires are secured in the terminal blocks (and have good contact. I was really think that it might be some overtightened v-wheels. Does the machine return to the proper zero position on the “cut” is complete? Could you maybe post a video?

Check your x-axis wiring.

ErikJenkins, I have checked the x-axis wiring, aswell as all other wiring. It is locked in the right positions.

Rusty, yes the machine returns to the proper zero position (home) then the “cut ;-)” is complete. I will uploade a video of the process in a few minutes :smile:

Thanks for your input!

Something is catching on the X-Axis. Are the pulley set screws tight with one on the flat portion of the shaft? Is the belt running straight in the middle of the pulley (not off to the side and catching)?

It looks like power to the x-axis, I would bump up the current.

That looks mechanical to me. Assuming it’s cutting counterclockwise, it looks like the X axis is having a hard time moving until enough torque is applied. Once the torque picks up enough to move it, it breaks free.

It sounds like you’ve already addressed my first guesses, which would be tight V-wheels and pulley screws.

Is one of the pulley screws fully seated in the flat? Even a little bit of rotation due to a screw that’s slightly off could cause this.

Is there a buildup of dust on the rails or any of the wheels/belt parts?

What method do you use to measure your belt tension, and how tight is it? If the belt is excessively tight or loose, it could cause the same problem.

1 Like

Thanks for your time and effort! I have been making quite a lot tests now, and it is beginning to look better. Some of the V-wheels on the x-axis made a sligt noise then pushed the slide by hand, so I cleaned them up, tightened then and did some more tests. The result is good, but still not perfect. However I believe it is only a matter of fine-tuning the machine to get it alle working like a charm.

I will try to do a circle in wood now, hopefully it does not only work on paper :smile:

1 Like

It worked quite nice! However the diameter of the circel is only 11,8cm, and I should have been excatly 12cm. How can that be? I’m using a 1/4" bit, and it was cutting it as an outline on the outside.

1 Like

The true size of many bits is very often slightly different from the “stated” size. If you can get access to a micrometer or digital vernier callipers, accurately measure the cutting diameter of the bit and then enter this size into your machine as the bit size.

I have several bits which are quite a bit smaller than the stated size. I guess this means it’s possible to have bits that are larger as well.

Also, some metric bits are sold as imperial (or vice versa), with their size stated in inches instead of mm. This can often be a source of some difference in sizing.

This could possibly account for the difference.

just as david said… i had the same issue until i thought to measure. now i have a database of all of my endmills so i know what to program for. just make sure you grab the correct one when you go to cut. made that mistake tonight. it was off by .015, but add that to the compensation i already created of .01… now we are at .025.

You may need to calibrate the stepper motors. It’s pretty easy to do, I made a video that’s in this forum: X-Carve Maintenance/Troubleshooting Videos - Add Your Own!.

I will try to calibrate my stepper motors today, to see if that helps :)! Also gonna measure my bit to, didn’t think of that! Thanks for the help :smile: