Change Baud Rate

Continuing the discussion from Firmware issues:

I’m not sure where “Device Manager” is. Help?

I want to change the baud rate on my XCP. To be honest, I’m a little miffed that a change like this was made at all. It locks us out of using OpenBuilds Control. And I’m not too fond of the idea of reverting back to a previous version of the firmware, because that is asking for old bugs to reappear.

1 Like

on wndows, click or press the windows button an type it “device manager”


Oh, this is an OS thing, not a software thing. Got it!


So would this change it on the XCP permanently? Or at least until another firmware update changes it back.

1 Like

Yes, until you change it back.
The firmware is open source, so you can change it whenever you want to whatever you want. Unfortunately, it’s a compile time option which means you have to edit and reflash the firmware each time.

1 Like

I’m confused. I just:

  1. downloaded the old firmware,
  2. added it as a library on Arduino IDE,
  3. connected to XCP
  4. compiled it
  5. I tested my access to the machine within Arduino on port 115200, and homed it
  6. closed Aduino and opened OpenBuilds, where I tried to connect. But it failed to find the machine on the port.

What is going on?

Did you close the Arduino connection?

I closed the app. Does that close the connection?

Make sure you don’t have anything else open that could connect, like easel. And power cycle the Xcarve.

All closed. And that brings up another weird issue. If I do open up Easel, it connects to the machine just fine. Makes me wonder if it automatically uploads the newer firmware or changes the baud rate.

It can’t do that without your connecting it first.
You were able to connect at 115200 with the Arduino serial monitor?


1 Like

It should be able to connect then.
I’d try unplugging USB, closing all applications, plugging USB back in and then open OpenBuilds.
If that doesn’t work, restart computer.

Looking above… Did you change any windows settings?

I’m on a mac. I didn’t change any settings there.

Sorry, I noticed that and forgot as I was replying.
Were you using OpenBuilds prior to all of this?

Restarted. Still no dice. And I can still connect via Arduino.

I used it a long time ago. Prior to the firmware update.

Maybe I should reinstall OpenBuilds?

Don’t think that would do anything unless there’s an update, but it won’t hurt.
I wonder if the XCP string after the hecyk welcome message is causing an issue…

1 Like

Try gSender. I know it’s not your end goal, but it’ll help with troubleshooting. It’s a pretty good program too.