Changing bits, keeping home position

I just tried running a rough/detail carve on my x-carve, and had a problem. After the rough carve was done, I had to move the spindle away from the wood to be able to get the bit out to replace it with the detail bit. Then I tried to put it back in the same place to start the next carve, but you can guess what happened.

Basically, I moved it 20 “clicks” on the Y axis (set at 0.01" per click) to be able to get my 1/8" bit out. Then I put in a 1/16" bit, moved it back 20 clicks, and then re-set the “z” to the top of the material, then did my detail cut. From the results, looks like the x/y position was pretty good, but Z was not quite low enough, so the detail pass left a tiny little “step” at the bottom of my letters.

So, first, is there a better way to get back to the exact x/y “home” position? And then, how do I make sure I’m in exactly the same Z home position, given that the new bit is shorter than the old one? Is there a technique I need to use here?


1 Like

Jogging is not going to change your position for X or Y. Don’t set zero. keep it where ever you jogged, only do Z0 after change your bit. start your job you’ll see, it goes to zero first than start carving.

1 Like

Regarding setting the zero on your z-axis

If you’re using Chilipeppr or UGS, you can look into getting a “z-zero touch plate” (you should be able to search for that on the forums here) which can be used to automate this step. I imagine it’s on Easel’s “to-do” list, so maybe in the future they’ll have this functionality as well.

If you’re using Easel, this is my technique for manually adjusting my z axis: I’ll jog the spindle to the center of what I’m going to cut, and jog the bit down until it’s maybe 1cm above the work piece. I’ll then take a small piece of paper (like a post-it note or some scrap), change my jog speed to a smaller increment, and slowly bring the bit down. I’ll wiggle the paper back and forth slightly, and as soon as the bit touches down, it will stop the paper from moving. I then move it back up one notch, remove the paper, move it down two notches (assuming your jog step is about equal to the thickness of the paper), and then zero out my z axis…

1 Like

VID_310820519_085058.mp4 (2.5 MB)

i use this plate to zero the Z as shown and also i hold it against the side of the material and i can set X and Y as well

best thing ive done to my X carve other than the dewalt router

@BadWolf, is there a tutorial somewhere, or can you explain, how to set that up on the X-Carve?

Here’s a thread on the topic:

1 Like

Will you please detail how you accomplished this? How is it connected to the x-carve?

hi james. did you check out the link i posted? keep in mind this was done using UGS and not easel. not sure it will work in easel

the basics are you connect one wire to the A5 pin on the arduino and to a plate of your choice and another wire to a ground on the arduino or gshield and an alligator clip

Ok, thanks, am using easel for now. So will wait for inventables to release their touch plate design.

Here is my latest, all positive comments welcomed.

You cannot change the cut depth between the rough and detail, just set the depth you want and then leave it alone for the Rough and detail. If you want the letter to stand up .25 inches then set the depth of the rectangle to .25 inches and don’t touch it again. Just do the rough cut (at .25 inch) and then do the detail (at .25 inch).

To get a smooth bottom you need to be sure you are using a flat bottom endmill.

I have used the “dual” carve many times in Easel, it works very well.

Allen’ that is what I did, I must have not been clear on what I said. I set the depth to 1/8" and that is all I did. I set the text at ‘0’ inches. Didn’t change anything after that. I also used a 1/4" flat bottom end mill for the rough carve and a flat bottom 1/8" end mill for the detail carve. Every attempt to do a dual carve has resulted in the same problem, it carves the outer edge and around the letter’s to this .25" depth and leaves a rather rough carving in the middle. It did this prior to my adding the dust shoe and steel bracing and it did it after. Also after the rough carve it pops up the pull down menu asking me how did it carve as if it is finished. Don’t know if this is correct and then I have to go in and go through the set up sequence again to get to the ‘detail’ carve menu to finish. Don’t know if this is the way it works or not?

When you are doing a two stage carving (rough and detail), Easel considers each stage a separate job. The roughing stage has its toolpath based on the rough bit size. Then the detail stage has its own toolpath based on the detail bit size.

So yes Easel will act as if it is completely done after each stage.

If you are not changing the cut depth between the rough and detail then the only possible source for the results you are seeing is that you are not correctly setting the Z zero for the detail bit. Be sure that after you load the detail bit into the collet you then lower the z axis until the detail bit is just touching the work surface.

The X and Y axis zero’s MUST stay the same for the rough and detail bits, but the Z axis will need to be re-zeroed before the detail cut because you will not have the same amount of tool sticking out of the collet.

Thanks again for your input, but yes I am doing all these things. I am re-zeroing the bit as closely as I can to the rough carve ‘zero’ point ( within a paper thickness or less ) and it still does this deep carve I pointed out in the video. This has done this every time I have attempted a dual carve.

OK, so lets go over what you are doing.

When you run the rough stage cut, it should be cutting the depth of everything it can reach in the rectangle to the .125 inch depth you set. The only parts that should be uncut after the rough stage are the small areas around the text where the ,25 inch bit will not fit. The bottom of the pocket should be smooth (except for some places around the letters). Is that what you are seeing after the rough stage is complete?

yes that is correct then I tell it to do the “detail” carve and it does that. In addition during the “detail” carve it carves the edges of the square and around the letter’s this additional depth which I measured at .25". I did not tell it to cut at this deeper depth, it just does it on it’s own. It has done this since day one. During the “detail” carve it seems to be carving over the ‘rough’ carved area and cleaning up around the letter’s, but it leaves area’s untouched for some reason?

Just re-read you last, during the ‘rough’ carve most of the area is smooth except for parts that are left a little ragged/rough as if it missed smoothing some parts.

The rough cut should never cut deeper than the 1/8 inch you set for the depth of the rectangle. If the rough cut is cutting deeper then that is what is causing your problem and what we need to fix.

You need to do a test cut of a small 2 x 2 rectangle with a depth of 1/8 inch using your .25 inch bit and then measure to see what the depth really is

I just missed the last one James, did you say you’re zeroing on rough cut surface for the second bit?
If you zeroing on same surface for both bits, which is raw surface any bit didn’t touch yet, you must be good.

You said;

"I am re-zeroing the bit as closely as I can to the rough carve ‘zero’ point

( within a paper thickness or less ) and it still does this deep carve I pointed out in the video. This has done this every time I have attempted a dual carve."