Chilipeppr and large G-Code files

Hi Erik,

Our Internet service is going in and out here, so sorry for the delay. Look for your registration email in your inbox.

Thank you.
Jeff

All good, testing it out now. Thank you!

The second test with PicSender had a USB error at 70% and trashed the piece…glad it was a test.

Do you have the USB power management disabled in Windows?

never had an issue with any other program with USB…I will check, should it be disabled?

Just checked what that was for…I am running a desktop with all power management shut off…the system will never sleep or hibernate or shut anything off…It is configured for my CNC machine only. That is not the issue.

Just verified…the USB piece is disabled.

i use ugs had the same issue i ended up increasing the allocated memory for java that solved my large file issues dont know if the chilli runs under java. http://www.wikihow.com/Increase-Java-Memory-in-Windows-7

I’ve never had the issue with UGS…even with very large files.

i could run 20000 lines fine but more than that got sketchy the project i am cutting now is running 125 ipm on a 30x30 3d relief been 36 hours so far and no probs yet. but anyhow thats what worked for me. there are so many computer configurations what works for one might not work for others

I’ll take a look at those settings…looks like I will be going to UGS now for everything. I ran a 750k line gcode file (15mb file) the other night on UGS with no issues.

The part that crashes ChiliPeppr is the 3D Viewer. The viewer loads a 3D line between every point extracted from your Gcode file. So, the crashing you’re getting is because the 3D view is overloading your browser’s memory. You’d think that the browser would gracefully fail to load the object rather than just crash, but I guess ChiliPeppr pushes the limits of what the developers have tested.

One thing you could try is to disable the 3D viewer in the pulldown menu near the “Simulator” choices. Then load your file and you may find it works just fine. We could also perhaps do a workspace where the 3D viewer is removed and then this would all work just fine.

The other option for the future is to perhaps just render a partial amount of the 3D points so there’s no crashing.

I do prefer Chilipeppr, so I will try disabling the 3d viewer for large files. Too late to test now, but I will see if it loads tomorrow.

I’ve had issues with UGS 3 or 4 times now where a large project (40k lines or more) will “crash” UGS and the X-carve will cut super slow. On the first project this happened on, it would get about 60% through the job and UGS locked up, and essentially the machine will move/step about 1/50 of the normal job speed. I would have to go into task manager to kill UGS and re-home the machine and start the job over again. After the 3rd attempt of running that project, it finally ran all the way through without any issues. Last night, I ran a different project, but also over 40k lines, and UGS locked up at around 60% completion. Guess I’ll need to increase the allocated memory too. Hopefully that does the trick!

I am now running files in excess of 750k lines with UGS. I prefer chilipeppr (mostly due to the interface), but I will continue to use UGS now until Chilipeppr is functional with big files.

1 Like

have you tried the latest working nightly builds i have had good luck with them
https://winder.ci.cloudbees.com/job/UGS/369/

1 Like

I haven’t yet…I’m using 1.0.8 right now. I ran the same project a little while ago after upping the memory allocation in Java, and it still locked up again, this time in an earlier spot than yesterday. I’ll try the nightly build tomorrow.

I couldn’t resist…

2 Likes

Erik, would you be up for sharing your worst case files so I can try to test them out in ChiliPeppr?

I would be happy to, I will send it to you when I get home from work.