Chilipeppr Auto Level stopping?

Hey all,

I’m trying to use the Chilipeppr Auto Level feature for the first time and I’m having some issues…

I’m 99% sure I’ve got it all wired up correctly, as the test probe runs just fine. When I hit play on the auto level, it goes to (0,0) as expected, descends to the board, then stops at the right place. Then nothing… the command stopped correctly when the probe touched the board, but Chilipepper doesn’t seem to get the message to continue on to the next sample.

If I hit pause/play, it then runs the next step, (0,5) in in this case, and descends to the board, and stops again. Hitting pause/play repeatedly keeps going one step at a time. It seems to be recording the data properly, but it does not reset the 0 position to the probe at (0,0), which I imagine will cause issues when I try to etch the board with the warped gcode that is now no longer zero referenced. And of course hitting pause/play 180+ times gets old pretty darn quickly.

Anyone else seen this? Any ideas what I’m doing wrong?

X-Carve 1000x1000 w/ gShield
Probe wired to A5/GND (it does stop correctly 100% of the time, so pretty sure this is right).
Tried running Chilipeppr from both Safari and Firefox (both up to date) under El Capitan, with identical results.

Also - anyone use a pull up resister on the probe? It seems odd to me to be using the floating voltage as a reference point - I would usually expect to pull that up to 5V to help with noise.


If anyone else runs up against this, it appears from the chilipeppr forums that this is a new bug introduced in the last few days. It’s apparently been fixed in the TinyG version already, but hasn’t been fixed over in the GRBL version yet… However there is a fork that someone built that does have the fix we can use. Seems to be a moving target, so please reference the chilipeppr G+ community for the latest forked version until they get it fixed officially…

1 Like

For others that experience this problem, I had the exact same problem, it turned out that my spindle generated some sort of noise, disconnecting the spindle solved it for me. (i used a dremmel as spindle).