Chilipeppr crashes

If I load a small .nc file into Chilipeppr/grbl running in Chrome all is fine but when I load a large file it times out, asks me to Kill or Wait and if I select Wait, it runs a bit longer and then the browser crashes. The .nc file is 2.5Mb.
Anyone else had this trouble?

I had issues with Chilipeppr and large g-code files. I ended up switching to Universal G-Code Sender.

Happily sending 5mb files here with CP on a MacBook from Chrome.

Have you tried latest version of Chrome or maybe Firefox?

Cheers

Ian

I’m using the latest version of Chrome. I’ve also tried Firefox but that’s not much better. When I eventually get the gcode loaded (after hitting continue several times), the axis controls run really slowly and the gcode program won’t run at all.
I’m loathed to give up Chilipeppr because other than this issue I find it really good.

I’ve been using a new program called grblControl, which can be found on github. It’s written using Qt, so it’s crossplatform, and is extremely fast compared to CP, UGS, Easel, etc… The only downside is that it converts everything into metric and operates using millimeters all around, which is why I hacked my own custom version that runs in inches instead. It has an autolevel feature, feed override, and all the usual bells and whistles you could want from a CNC controller program. I found it after discovering that my massive NC files couldn’t be handled by anything else as well.

I’ve found grblControl on GitHub. How do I run it?

just download the zip… go to https://github.com/Denvi/grblControl and scroll down below all the source code files and there are binaries for windows and linux of the latest version.

https://github.com/Denvi/grblControl/releases/download/v0.8.1/grblControl_0.8.1.zip

is the latest windows release.

thanks. All running now and doesn’t crash like CP. Cheers

1 Like