ChiliPeppr + X-Carve : Will it work?

yes ive gotten it to work with easel and ugs so far, havent tried to cut anything out with ugs yet but all the controls work so far. i did do some carving on easel

will be trying some stuff with ugs soon. but I would like to try chilipeppr to see which i like more. ugs or chilipeppr

@JohnLauer any ideas why it would work with Easel and UGS but not chilipeppr?

Well tried carving on ugs and we’ll broke my end mill, couldn’t zero out the machine with ugs by pressing reset zero as it was giving me the error unsupported command. So I tried to manually zero with G92 X0 Y0 Z0. Well that didn’t work as it lifted the z axis and ran right into one of my clamps and broke the end mill right off. Not only that but I let it run to see what it would do, wasn’t milling in the right spot. I shouldve used G53 command. Now I have to order a new end mill to carve out what I need. Will be trying to zero on ugs later today.

Make sure you have the latest version of UGS to resolve the unsupported command issue.

I still don’t really know what the Return to Zero button in UGS does…I’m pretty sure it’s for when you want to quickly crash into the rails. You would think it’s for returning to the zero set with the “Reset Zero” button right next to it…but no.

Chilipeppr looks really good, I’ll be trying to move to that.

ChiliPeppr should work fine as long as you’re in the Grbl workspace rather than the TinyG workspace, i.e. make sure you’re at ChiliPeppr - Hardware Fiddle since that’s the correct workspace.

BTW, you do not need to be logged into ChiliPeppr for it to work. Only a few small items require a login like the webcam widget so the server and client can find each other.

ChiliPeppr is much like Easel in that you go to a URL in the cloud, but you only go to that URL to load the latest codebase. Once the Javascript is loaded in your browser, it’s the equivalent of a desktop app. The browser talks direct to Serial Port JSON Server on your local machine or local network, i.e. a 192.168.1.* address at your house.

You can send unlimited file sizes and it’s very high performance. The reason this works is buffering. You’ll see that ChiliPeppr shows you the amount of gcode lines buffered onto SPJS. If you are on a Raspberry Pi, it’s the one getting the lines buffered. That way SPJS is able to yank the next line in milliseconds to keep feeding the Gcode controller, and thus you get pretty much perfect performance.

Enjoy.

1 Like

For Chilipeppr, I just installed and ran their serial driver, and, it was fine, except for the spindle control. That may not be true as I just noticed that the spindle selector switch was off.

Ok so I got chili pepper working but it can’t seem to cut as expected. Cam hsm cam pro for inventor pro, uploaded to chilipeppr and the image seems fine. But when I zero the machine and start the code it’s just not right… ive also zeroed the machine moved it and tried to go back to zero it doesn’t go back to where I set as zero. Anyone have had this problem? Checked the machine and the belts aren’t slipping everything is square.

My only guess is that you are using G92 to set temporary offsets thinking everyone will be perfect, but then your Gcode you are running is doing a reset in the Gcode which turns off your G92, and then your machine goes to a weird spot. If that’s the case it’s not your hardware or ChiliPeppr, it’s simply your Gcode. Perhaps try to not use G92 and rather just set your machine coordinates. I made the Zero Out button in ChiliPeppr be machine coordinates just to avoid this question ever popping up, even though may would say a true Zero Out should be a resetting of G54 or G55 or G92.

well after unplugging, and restarting chilipeppr several times, i somehow finally got it to work. it works great, just that when i zero something out and hit run it goes to some spot, pauses asks me for a tool change, i hit run and it runs as expected. only thing is that it damaged my work piece because it didnt lift the end mill before moving. hopefully this was my error. im having better luck with chilipeppr then i had with ugs. i think ill stick with it. just want to learn a bit of gcode so i understand what is actually going on. and i want to learn how to get the exact results im looking for.

I tried getting ChiliPeppr to work with the X-Carve today with no luck. It connects and can control the machine, but I’m having some odd issues. When idle, every 3-5 seconds the machine makes a sound like it’s moving (just a quick twitch) and an error message pops up in ChiliPeppr saying GRBL has reset. I’ll try and dive a bit deeper into it later, but I’m so frustrated with the machine I’m taking a break for a few days.

I had the same issue when I was running UGS at one point, but then I realized that I also had an Easel window open. Make sure that you aren’t running UGS or Easel when you have ChilliPepper open. Just something to double check.

1 Like

Ah! That could totally be it. I’m pretty sure I had an easel browser tab open somewhere. I’ll give that a shot, thanks!

Hopefully that was it… It’s nice when it is something simple.

Sorry to stir up a 3 week old forum, but if you haven’t heard of it look into the ESP series of wifi modules/microcontrollers. And I say module “slash” microcontroller because it can function as either. There are arduino compatible libraries that allow it to function as a wifi module and more recently the ESP8266 has been ported to be programmable through the arduino IDE, with several GPIO and a serial bus. A suggestion for your hackerspace would be to create a local server that holds project files and have your raspberry pi monitor for a new file to be added. Of the ESP series (there’s about a dozen different physical variations based on the same chipset) I’d recommend the ESP12, which has the most available pins on the breakout board.

@VexFX - Did you get Chilipeppr to work? Right now it’s my go-to app for running my gcode, I’m really digging it.

@JohnLauer - You mentioned on another thread that my problem with running subsequent gcode files might have to do with it not sending an M30 command at the end. I just went through some recent mail on the grbl dev list, and I came across this:

Everything works fine with Grbl 0.9i, except the M30 command.
Grbl answers OK but looks frozen after a M30 is sent, the spindle is still running and the job is not considered as done:

G0X0.0000Y0.0000
M30
ok
ok

to which Sonny Jeon replied:

Update to the current v0.9i build. This problem has been fixed.

So I guess maybe v0.9i is being treated as the current development release. I’ll try to update to that and see if the problem goes away.

Yeah, that M30 issue is what I was thinking could possibly be your problem. If you upgrade your firmware, could you let us know if that fixed your freezing problem after the file was done running?

Well, just updated to the latest version of grbl v0.9i and I can now execute multiple runs sequentially, so yay!

Except… now when I use the home feature in Chilipeppr, it correctly performs the homing moves, but then it doesn’t zero out the x/y axis values. Tried it several times and it seemed to happen every time. Maybe there’s some setting in grbl that got wiped out after I uploaded the new version, I’ll have to do some research and see what I can find.

Also a minor note, the M30 issue didn’t seem to affect Easel, I was able to draw a square and have it run multiple times. Maybe Easel does a disconnect/reconnect between runs and that bypasses the problem.

I think I saw the zero issue was a matter of the units being reset/changed.

I don’t think Easel bothers with issuing the M30. Most Gcode doesn’t bother with M30.

@PeterJames I’ve not had a chance to revisit ChilliPeppr (or the X-Carve) yet. Every time I have free time I’m so demotivated by my recent discovery that the design of the machine does not account for work surface leveling that I just don’t want to deal with it. It’s sad that such a simple (but serious) design oversight has taken all the wind out of my sails. Hopefully I’ll find some motivation soon.