Chilipepr and GRBL error


I am trying to get handle on the gcode senders and am trying chilipepr.

I assume that the GRBL is the correct workspace, but one I connect to the serial port I get the error “You must connect to your GRBL device using the GRBL buffer algorithm in this workspace.”

I saw another thread that the buffer algorithm is selected by clicking next to the Serial port assignment, but there is nothing there to select besides the port speed.

Before you hit the checkbox to connect, choose grbl in the drop down instead of default.

Also don’t use the most recent version of the json server, I think version 1.8 works… last time I used the most recent one I was having problems with the most recent one, turns out it’s the arduino library was updated and in the json server and the arduino withe the grbl controller wasn’t able to communicate correctly

Ok, am using 1.8 and @ErikJenkins that worked…thanks.

Send a gcode file to the unit and it carved but cannot get the Jog functions to work.

Are you using the keyboard to try to jog? If so, click on the jog widget first then you can use the keyboard…it has to have focus. make sure no alarm is indicated on the center, right widget.

Hi Erik,

I tried the keyboard but that just moves the screen around. I did a Ctrl-X and used the buttons on screen and that worked.


After you click on the button on the screen, the keyboard shortcuts should work.They need to have focus.