Circles in easel vs Aspire + UGS

That could of course be it but circles in easel are perfect. Very strange…

I can not get this to work properly with aspire + UGS. Easel works perfect though and when I run the g code exported from easel in UGS it works perfectly every time.

I noticed the exported G code from easel has as .nc file format. Which post processor does easel use? Is there a similar one in aspire?

What feed rate, depth of cut and spindle speed are you setting up in Aspire?

What feed rate, depth of cut and spindle speed are you setting up in Easel?

Same in both. Feed rate: 700mm/s. Depth of cut: 0.7mm.
I have manual spindle speed and I’m running a DeWalt DWP611 at about 4.

I made two circles, 100mm, and 95.8mm which should make a 2.1mm slot. Easel makes a perfect slot for my inlay strips but aspire makes a slot that is 1.8 to 2.6mm wide. I set the center of both circles to X0, Y0 in aspire to make sure there was no misalignment.

Really appreciate the help :slight_smile:

It really sounds like the postprocessor if everything is the same. One thing, your dewalt is set way too fast…I would bump it down to 1 instead of 4.

Thanks! I usually run it at a lower setting, just wanted to make sure my problems wasn’t because of low rpm.

I thought It might be a post processor problem as well, but the visualize option in UGS looks very good. I expect 0.8mm would be visible there. Maybe I should re flash my arduino or something? On the other hand everything runs perfect with the easel G code. Very frustrating.

If I draw a 100mm circle in Inkscape and set the lineweight to 2.1 mm, use the convert stroke to path and try to cut that in easel I get the same problem. But not when making two circles in easel, 100mm and 95.8mm. Very strange!

I’ll donate $100 to the first one who gives me the solution to this problem, I’ve tried for 4 days now and I’m getting tired of it :slight_smile:

I don’t have a solution for you, but I did run a test just now. I use VCarve Desktop, which is a subset of Aspire. Anything I do in VCarve can be done in Aspire. I set up two circles of the diameters you described: one at 100mm, the other at 95.8mm. I set up a pocket path between the circles using a 1/32" endmill and saved the toolpath. I use the Gcode_Inch PP and my electronics are the same as on X-Carve. I ran the gcode and got circles that measured exactly the same in both the X&Y axes. Each circle measured the same as was drawn and the distance between is 2.1mm.

Here’s my gcode file, of you want to test it: (28.1 KB)

OK, I REALLY hope @PerMarklund found a solution to this, because I have a similar problem. Circles drawn in Easel come out perfectly straight, while circles drawn in Aspire are not. I tried slower speeds and shallower cuts to see if it was a stepping issue, but there seems to be another factor, and I believe it is the post processors. I tried both the “x-carve in” g-code export and the Easel post-processor with the same results in Easel or UGS.

Is anyone else seeing this, or fixed this?

I have received tips that you should have 3.5 pounds in the middle
Is it wrong ?

When you save your tool path from Aspire what do you save it under. Easle or xcarve?

Mm I just read through the thread and see that in there already. I know when I save my toolpath from Aspire with the Easle Post Processor. It gets pretty crazy running it with UGS. I have to save it with XCarve PP. I’ve had it go the opposite direction it was supposed to when I started the cut. Tried breaking through my end plates.

I loosened my V-wheels a little bit and it got better. But in the end the X-carve wasn’t accurate enough for the kind of work I do. ±0.1 mm here and there just doesn’t work for me. Perhaps I would have been able to get better results but I don’t have time to adjust and calibrate all the time. So I sold my X-carve and got an Xzero raptor which is incredibly accurate but cost quite a bit more. Even though I sold it I had a lot of fun learning on the Xcarve and never would have gotten into CNC without it. Thanks Inventables!

Almost forgotten post, but Yesterday I’ve got a similar problem:

I made circles in Aspire and cut them using Easel (I know, I should try UGS, but … :slight_smile: ) - circles was more like an oval (in Y-direction). Then I checked steps per millimeters, belt tension, checked all screws and remembered that when I tried to cut circles in Easel everything was OK.
So I made my needed drawings in Easel and cut that - the result was pretty good.
For now - fast workaround is to do cut in Easel.

But, probably I need to check Aspire settings somewhere?

for Easel

yes, but about 3 months ago.
Will download the latest version - probably that was changed.

Easel does not support arcs, so to carve a circle it breaks the circle up into very small straight line segments to approximate a circle.

Aspire does support arcs and whether it uses arcs or not is dependent on the post processor that you use.

If the post processor has the arcs commands specified then Aspire will use arc commands (G2/G3) to carve the circle. In this case, grbl will break the arcs up into very small straight line segments to carve the circle. grbl has some user settings that affect the precision of the approximation.

If the post processor does not have the arc commands specified, then Aspire will break the circle up into very small straight line segments. I don’t know if Aspire has settings that affect the generation of the straight line segments or not.

Thank you, Larry, for an explanation.

Thank’s for the hint - will check the code in the evening.