Inventables Community Forum

CNC 3018 Problem!

Hello community,
I have purchased a CNC 3018 pro, when I connected the machine to the computer and used Candle, the machine moved on the X Axis (Up and Down) just fine, when I told the machine to decend 10mm it did and perfectly, after connecting easel and it wrote the configuration it messed my machine up, when I tell the machine to move the spindle 10mm down it only does 1.2mm down and up. I thought it may be a board issue as no one else has reported on this so I purchased a new board, worked fine again UNTIL it wrote the config again and now I am stuck with another semi-broken machine. Does anyone know the correct settings I should be using, at the mo I thing i’m using: grbl (Other) > Arduino (GShield) > Rail Size of 500mm x 500mm > ACME threaded rod > 24V DC spindle and no dust shoe. If anyone knows how to reset the board so it works again with Candle doing 10mm when I tell it to do 10mm would be much appreciated and I will just start exporting GCode from Easel.
Many thanks,
Charlie

In Easel, open Machine Inspector and in the Console window write $$ and press Enter
A full list of your GRBL parameters will show, take note of value $100, $101 and $102
$100 = X axis (left and right)
$101 = Y axis (back and forth)
$102 = Z axis (up and down)

You need to recalibrate these three values, check this video for reference:

Changing the GRBL parameter is simple enough:
In Console window just write the new value like this $100=xxx followed by Enter

1 Like

So how to I reset the value in machine inspector, eg. change it from the 188.976 to 1600.000

In Console window just write the new value like this $100=1600 followed by Enter
You may need to restart the controller to make the change come into effect.

It may require fine-tuning to get maximum accuracy out of your machine.

You are a life saver, nearly had to buy another board!!! Many thanks

No problem, glad it sorted your issues :slight_smile:

The reason for your troubles are that the parameters provided by Easel set up assumes a specific setting of microstep levels and distance per revolution. For the CNC3018 these are different hence the…difference :wink:

So by putting in the corrected values for the key parameters, in this case the step/mm value for each axis, you are good to go :slight_smile:
I recommend you write down (or screen shot) your correct GRBL parameters in case you need to reflash at a later time.

1 Like

PSA:
If you don’t have an X carve, don’t run the machine setup in Easel.

Lots of these recently.

3 Likes