CNC Halftone images - Using DXF halftone

I just finished my x-carve and the project I’ve been really wanting to start with was these CNC halftone images, done with a v-bit, such as this one:

There are few different programs out there, but this DXF Halftone seems the most promising. It creates the halftone image from any .jpg you send it and will export g-code. Being a total noob, I’m wondering if anyone could help with settings for the x-carve, especially on these two dialogs:

Also, I don’t currently own a v-bit and need to know which one to get. If you haven’t checked out this application of CNC, it is really awesome.

6 Likes

Well, in case anyone is interested (crickets…chirping), I got this program working on the X-carve. I used DXF Halftone on Windows (running on Parallels for Mac) to create the Gcode, then moved it to my Raspberry Pi and ran it with GrblController, which is simple and seems to work well (my first time ever using a Raspberry Pi or anything other than Easel). I used a 90 degree V-bit I bought from Inventables. Running time was 100 minutes for an image with 2450 dots. The resulting image was slightly under cut, meaning I didn’t have my Z zeroed deep enough, so what should have been 10mm circles were 8mm, making it look a little faint. Other than that, it worked well. I think with the Dewalt 611 it could be run a bit faster (still waiting on that mount). I plan to optimize the source image with a bit more contrast and re-cut it this weekend. Makes for some cool wall art.

5 Likes

Very cool! What material are you using for this?

I just grabbed some cheap birch plywood from HD which I spray painted. Once I get it dialed in, I’ll try some higher quality wood. I’ve seen it done with darker MDF, which is painted white on the surface and also gives nice contrast.

1 Like

You should sign up for this bounty, seems like it would be great for what you’re doing:

https://discuss.inventables.com/t/tip-jar-material-bounty-unclaimed-100-gift-card-free-material-black-mdf/9400/

If your halftone program can create an SVG file, you could import it into Easel and go from there. It might take a little bit of work figuring out the bit settings that would make your V-bit work, but it seems pretty do-able.

1 Like

There’s the catch. Each dot is calculated by the program to plunge the router straight in and out. I’ll have to see if I could output accurate vectors as tracings around each dot, then have Easel mill each as a circle. Sounds like a workaround to a problem that doesn’t exist (DXF halftone already does this much more easily). If Easel could just run imported Gcode…

2 Likes

Try FormPly mate - you can usually get it cheap with a black coating

Cool program, like this much better then Picengrave, at least from the preview screen. How do you convert the tap file to gcode for GRBL?

Hi, I’m trying to do this same project. Is it possible using halftone to get the gcode into easel? I don’t have raspberry pi. So I can create the dxf, but need to convert to svg or gcode. (When I converted to gcode I get an error I don’t understand about post processing?)

I like your project. I too am new. Would you be so kind and tell me a little bit about x-carve. I am looking at getting one but I have no CNC experience. Was it difficult to learn how to program the thing?

I’m looking to have it drill and tap about 60 m3 screw holes in a piece of aluminum. How long do you think that would take the x-carve to perform?

That is a really cool idea. do you have a picture of the finished project?

I downloaded v1.5 from this site. I tried it and it still works. I had to try and tweek it a bit but got it working pretty well.
The link is http://jasondorie.com/page_cnc.html.

1 Like

For those interested, I created a step-by-step guide here:

4 Likes

The link does not seem to work any more. Did you remove the step by step guide?

No, its still at https://www.inventables.com/projects/cnc-halftoning-step-by-step

I just checked.

Thanks for checking! All I seem to be able to get is the Inventables login page. No matter how many times I click on that login button (multiple computers and browsers) it will not allow me to view the page even though I am actually logged in. :frowning:

Sounds like a bug maybe. If you are using Internet Explorer (or Edge) try Chrome or vice versa. Hope this helps.

It’s not working for me either (Chrome). I get directed to the login page for Inventables (even though I’m already logged in). I tried logging out and again, same thing. Then used a different browser (Safari) with a clean cache. Same thing :-/ I read your writeup before and thought it was great! Guess it may be a bug in the site…?

1 Like

Contact Inventables. They are pretty quick to respond. Maybe you need to create a new account?

I am having the same problem. Just get the log in page…and it is a login p;age that will not die, just keeps returning to the login page again and again.

1 Like