COM Port Trouble with Logitech Unifying Software (?)

The Xcontroller has a FTDI USB chip which shows as a USB Serial Port just like you show in your image. The FTDI chip interfaces with the Arduino and so your computer doesn’t directly see the Arduino device, just the USB COM port.

Have you disabled power saving? It applies to non-laptops as well I believe.

Have you verified that the USB cable inside the Xcontroller is fully seated?

Try right clicking the USB serial port and selecting “Uninstall”. It’ll remove it but also it should remove the drivers. Reboot the PC. On reboot, in Device Manager, look for the device, it should be an unknown device. Download and extract the FTDI drivers. Right click the device and choose install driver and browse to the folder of the FTDI driver and select it. It should install all the drivers. Reboot the PC. Try again.

Your other option is to contact Inventables and see about a replacement board for the Xcontroller. It could be hardware related like a bad solder joint on either the FTDI chip or the Arduino that the heat from carving causes an issue with. If you’re electronically skilled you can go hunting to fix or just go hunting for evidence to show Inventables.

1 Like

When troubleshooting communication issues, eliminate the variables. Remove the Logitech stuff and use a wired mouse. Simplify first.

Baud rate should 115200 but that’s an Easel/UGS thing. The windows baud rate setting is a default but programs override it.

From the “Joke’s on Me” department: I switched internet providers a couple days ago. So, yesterday after updating my settings, I started the project again, and again it stopped. This time, it turned out that a guy from the internet provider had come out to bury the line they ran across my yard, and he disconnected it while I was running Easel online. How many other things can we think of to go wrong? :slight_smile:

I quit for the day after that. So I am going to follow Justin’s advice above, only, where do I download the FTDI drivers from? Will this be on a context menu on the unknown device?

Or, you can go directly to the chip manufacturer and get it for your operating system:

The latest version (2.12.24) is the version that Inventables linked to directly.

Ah, the blessed joy of seeing a project finish! I’d forgotten what it felt like. My entire activity with the X-Controller has been trying to get this problem fixed. No time for study, experimentation, learning, joining in conversations on other threads.

I followed JustinBusby’s directions to uninstall and use new drivers. It didn’t go quite like that, but close. The USB serial port only appears in the device manager when I turn on the x-controller. I uninstalled, it disappeared, I rebooted, opened device manager, and it wasn’t there either as a port or an unknown. Turned on x-controller and it showed up as the USB serial port again, not as unknown. So I told it to update its drivers.

The original drivers I had, dated 2/6/2017, were in an executable named “CDM v2.12.12 WHQL Certified.exe”. The file I downloaded from Inventables today is named CDM21224_Setup.exe. When I went to FTDI, they had Windows 32 and 64 separate, so I took 64. Its name is CDM v2.12.24 WHQL and it didn’t contain an executable; it was the drivers themselves, with associated .inf and .cat files and so on. this was the one I used.

With the new drivers installed, I started, for about the 6th time a project I created. This time it continued to completion.

I know better than to assume all is well, but I’m sure hoping. Thanks Phil, Justin and others; your willingness to help is greatly appreciated.


Good to hear and keep on carving! Post projects!

So… no, it isn’t fixed. Still stopping in mid-cut. One time, I got through all the variables to “Raise the bit”, and it quit between that and “Carve!”

I have two USB cables, the original and what came with the upgrade. I’ve tried both.

Phil mentioned reflashing my controller. A thorough search of the forum found numerous threads that mention it, but none that tell what it means or how to do it or where to find out how to do it. My best guess is, in Easel, go to the Machine menu, click Advanced, and click Upload Firmware. Is that it? If so, then how about if we stop calling it “reflash the controller” and start calling it “upload the firmware” for clarity?

Anyway, I did that. Here goes another attempt.

Based on other threads, it appears like maybe there are some issues with the USB bulkhead connection. Might want to look into that as a possibility as well.

1 Like

'scuse my neophytism. Does “bulkhead connection” mean the female jack on the controller?

Okay, I pressed the USB cable connector to the right in the jack, and my blue Carve button turned green, so yeah, not a good connection there.

1 Like

Yes. Sorry, used to calling panels that at work.

How tight did you tighten the screws? I remember mine being a PITA and thinking they were all the way in but the actual jack was being pressed inward.

Yes, the screws are tight. Based on this thread:

…I opened the controller box, but I didn’t see anything inside that I could plug this cable into. If it had a mini-connector on one end, I could, but oh well. So instead, I took my tiniest flat-point screwdriver and pried the two copper connectors on either side of the female jack out farther, so that they both press against the male jack. I haven’t run a project yet, but the Carve button has been staying green while I fool around since I did that.

Aaaand that was not it. I give up. I’m going to return this ______ ______ ______ machine along with a bill for hours lost.

Just making sure but you’re fully seating the USB cable into the front panel and its a tight/secure fit, right? It’s not vibrating loose during a carve? The same for the pigtail from the front panel to the board?

This sounds vibration or temperature related. Either a cable being loose or a bad solder joint.

Have you contacted Inventables at all? This might be a circuit card issue and this thread should give them plenty of background. The customer support they offer is top notch.

1 Like

Okay. Maybe a night’s sleep will help. I’m actually in physical pain from knotted muscles trying to suppress frustration and anger.

1 Like

Sorry, we aren’t open on Saturday. They will pick up the case on Monday.

Does the green light on the X-Controller turn on? Do you hear the fan?

If you reinstalled the Arduino it’s possible that GRBL isn’t on there anymore. That would give you the clicking.

Have you tried a different computer to validate that you are getting the same response?

That seems odd. I would expect it to dole the g-code out to the machine a little at a time. Does does the arduino have ram memory for storing a complete g-code set of instructions, such that Easel sends the whole thing at once and closes its connection while the CNC processes it? And if that’s the case, how does it send a Pause or Cancel?

I saw above that Inventables support won’t be available until Monday. I won’t invest any more time in this issue until then. I’ve gone back to my saws and drills to get this work done.

1 Like