COM Port Trouble with Logitech Unifying Software (?)

1.0c is what mine had before I reflashed, and 1.0c is what it reflashed with. Is LarryM’s different from Easel’s?
My most recent Windows updates were January 10 - KB3213986, and January 25 - KB3211320. Neither mentions ports or USB.

Let’s go a tad different route…are you Xcontroller ribbon cables secure? If the stop carve button pin wiggles a little, it may trigger an abort which could be what you’re seeing

I still think this is a manufacturing issue with the soldering of components. It happens all too often unfortunately.

Okay, I have downloaded LarryM’s modded version, the update from The readme file says the reason for this mod is to accomodate a J-Tech laser module, which I do not have. Do you know of edits he made that would help with my (our) issue?

JUstin, thanks, my cables are secure. I checked that when I opened the box yesterday looking to bypass the USB jack.

I wasn’t reading that thread and had a thought about that maybe could be causing the issue here which was presented as aborting during a carve.

I’m not saying what you’re saying is wrong, just throwing out other potential solutions to an issue. There’s been plenty of other instances where ribbon cables have caused issues as well.

If using just a different HEX works, then by all means use it. Could Inventables have another issue with the firmware being flashed like they saw late last year? Maybe.

1 Like

Incidentally, in searching for LarryM’s edit I found the thread, “Good Grief! More smashed Z switches”, (Good Grief! More smashed Z switches) which was interesting to me because my machine has smashed two of them so far. I’ll be adding the bolt in the threaded hole to prevent that.

Soft limits is something I just read about and still have to be educated on. I came to CNC with no knowledge of it at all, and haven’t found a clear and simple step-by-step beginner’s study guide. I had the impression that the switches kill the power to the stepper motor when tripped, but I guess not, if a switch can get smashed. At least, not every time. I tested it with my finger and it stopped the carriage. shrug

1 Like

If the Xcarve used true limit switches then what you’re saying would be right. However, the Xcarve uses homing switches which, by default, are only monitored during a homing sequence. GRBL supports hard limits which means a switch trips the alarm but most people just opt for soft limits.

LarryM’s instructions say to save my current grbl parameter values. Would that be by going to Easel’s Machine menu, Advanced, Machine Inspector? It has entries for State, Machine Position, Work Position, Console, Events, and Settings.

1 Like

This part is done. Now searching for how to set soft limits. Note: with Easel open it couldn’t open the port. Had to close it and reboot.

It looks like my axis limits are correct for my machine:
$132=100.000 (z max travel, mm)
$131=790.000 (y max travel, mm)
$130=790.000 (x max travel, mm)

So what do I need to do now, to set soft limits? is it $20=0? Or just $20 by itself?

Edit: on further reading, it seems I need to do:
to enable homing and then soft limits.

Loading it didn’t cause any errors. I’m still puttering around with the soft limits thing, trying to make sure I do it right, before I run a cut.


Earlier in this thread I asked half-jokingly how many other things could go wrong. Add this one to the list: the material pulled free of a clamp and began to scoot with the spindle. Slap the red panic button. Try to raise Z 2 inches. No response. No response in any direction, even after stop-start the controller and reboot the computer. Tried it in UGS and saw an alert about the z limit. So I sent the command $20=0 to turn them off, and it let me raise the spindle.

It was working on a piece which is a round box lid, cut out and held with tabs. The bit was down at the bottom, making the last cut. I don’t know what would make it think it was past the z limit. Maybe it has to do with stopping it with the red button as I did.

But here’s the good news: this was the second g-code file. It made it all the way through the one before it with no trouble, and it wasn’t the random stopping error that blew this attempt. So hooray for that much.

At the rate I’m using up material in failed attempts, I’m going to need to make a trip to Home Depot soon.

1 Like

When you hit the big red button, it turns off the Xcontroller which causes a loss of home position and when you turn the machine on again, the position you turn it on at becomes machine zero until you run a homing cycle so, with soft limits enabled, you would violate the soft limit since the Xcarve by default operates in negative space and having the spindle down low and having that be zero, trying to jog it up would violate the soft limit so it won’t work.

Does that make sense?

Yes. And it does seem that Larry’s grbl did it, but I’ve been fooled before. I’ll accept it after a few miles of uninterrupted cutting. :slight_smile:

1 Like

I’ve not carved a lot on my machine due to various reasons but it still amazes me every time I do a cut job.

Now it’s time to monetize that machine! I just had my first real sale to a non friend/relative on Amazon. It’s amazing the feeling knowing all the hard work, tweaking, tuning, upgrading, swearing, etc finally paid off, literally.

Let’s hope the GRBL reflash is all it takes.

1 Like

Heh - buzzing clamps… I imported a file that was 18 x 9, and I set it up as 9 x 18. My brand new, first time used 90 degree engraving bit went through not just the wooden clamp, but the screw that was holding it down before I could hit the stop button. Another one bites the dust.

1 Like

I haven’t been able to get back to it. Other obligations. I’m planning to do so this afternoon.

Finally back to CNCing. Happily, my toolpath ran for an hour and completed with no problems. Until it completed, that is. Using UGS, the latest nightly build, 3/13/2017. It returned the spindle to zero and told me it was done, so I told it to raise the bit 1.5 inches, which it did; and then I told it to move +Y 20 inches, which it didn’t.
At that point I found that the port was “busy” and I entered into several minutes of fruitless tries to get control back. The same UGS I had just used flawlessly now told me, even after a reboot, that “this version doesn’t have zeroing” when clicking $H and “this version doesn’t have unlock” (something like that) when I clicked $X.
Finally I went back to the old version 1.09, which worked and let me move the spindle. That’s how I got this picture. This is the rough-cut pocket toolpath that ran for an hour and completed.

Does that hold true if the port gets disabled/reenabled, if the UGS gets shut down and restarted, if the computer gets rebooted?

Most likely, no. Per the GRBL wiki:

“The non-persistent parameters, which will are not retained when reset or power-cycled, are G92, G43.1 tool length offsets, and the G38.2 probing data.”

I’m not sure exactly what homing registers Easel uses but I’m assuming it’s G92. GRBL does a soft-reset when connecting/disconnecting from what I’ve seen which would clear the G92 register.