Computer keeps on crashing

Been following the advice I got from some of you.

Reinstalled Windows 10 Pro
Use Chrome as my browser
Upgraded the memory to 8 gigs
Reinstalled the Easel driver
Screen saver, power saver are all set to off

Problem is, computer still crashes after about 10 to 15 minutes into a simple text carve. The design I made in V- Carve and transferee the code via USB into Easel.

I am at a point where I don’t know what else to do, other then getting a new computer. I had bought a refurbished Lenovo and figured that it should be enough to run a simple internet based program, and be able to handle the demands of Easel, which really should not be much in the first place.

Any advise beyond of what I’ve done thus far would be greatly appreciated.

Some specs on the computer, or the computer name/model would help in diagnostics…

A couple questions.
Is your computer previously upgraded from windows 7?
How is your internet connection, stable?
Also, it very well might be your usb cable.

It’s a Lenovo piece of crap. I went in and made some changes in the registry, as it seemed a com port was being denied access. After restart and firing everything back up I ran the second panel carve without an issue for 90 minutes until almost the very end. Had 2% left to go and it crapped out again.

Thank you for offering to help. The event viewer refers to not granting local activation permission to the com server application with SLSID. I set all referenced IDs to full access, and thought the problem was solved. Which of course was wrong.

The computer is a Lenovo ThinkCentre 7360 WDM running on Windows 10 Pro with 8 GB of RAM. Processor is a I5 Dual Core. I have no driver conflicts, device manager doesn’t show anything either. I am hardwired into my 1GB home network. All sceen and power savers are set to off, also any visual effects. There is no other software installed whatsoever. I am running Easel in Chrome.

Let me know if you need anything else.
Thanks a bunch!

I got the supplied USB cable that came with the controller plugged into a back port of the computer. If I need to change it, what do you recommend?
Thank you so much!

Sorry, I forgot. No, it’s a fresh Windows 10 Pro install. Running hardwired on a 1 GB home network.

And as far as power. I installed a dedicated line with its own 20 Amp circuit breaker into my box. Both the computer and the X-Carve run on that line.

I’ve read on other posts that there have been usb cable issues. Also It has been suggested to bypass the usb pigtail that hooks to the Xbox cover and go directly
To the circuit board.

I’m just a newbie but I use vcarve desktop and picsender totally eliminating easel and the need for a internet connection.
I’ve run several hour + carves with no interruptions.

Got more information on that Chris? Though, at this point I am not certain on what the actual problem may be.

I would think that if you are able to successfully go through all the steps in easel and begin the carve process, if the xcarve stops well into the carve the cause might be:
A momentary loss of internet.
A software issue with easel.
A computer issue such as usb connection.
A limit issue in the carve however I don’t think easel would have let you start the carve.
Some possible troubleshooting directions:
Try another computer.
Try another usb cable.
Check your internet connection.
Eliminate easel by using another cadcam program such as vcarve by vectric and a gcode sender such as picsender which cost money or UGS, as I understand is free.

Thanks Chris. Those are good suggestions. I’ll start with the usb cable and then move on to another g code sender. I already tried a different port, so that ain’t it. Not sure I want to move my office/gaming computer into the garage. LOL It’s a water cooled monster I build a couple of years ago and weighs over 40 lbs. Thanks again!

Good luck

Something I forgot to mention, a new post just reminded me.
Try a powered usb hub, that might be your answer!

@StefanSchroeder You say the computer crashes? What are you setting when that happens? USB cables, no matter how bad they are at carrying a clean signal, typically don’t cause windows to crash.
Does Windows crash if you aren’t carving?

Not thus far Neil. Only when I carve. When I work on something other than carving in the garage I run Pandora off the computer to my stereo. Never had it crash when doing so, only when carving. That would suggest it is not an internet or network issue, though I can’t be sure.

I will give the USB directly from the controller card a try next. If that’s not it I will get Easel out of the loop via another code sender. After all when I went into the error codes it pointed to a lacking COM port authorization. Don’t know if that would have anything to do with Easel though. If I still have the same issue it must be the computer itself. Though no IO interrupt issues or anything like that. I was thinking perhaps a bad USB controller, but it doesn’t show any problems either. I am a hobby enthusiast, by any means not an expert.

It’s just one of those things I guess. If none of this works I will get me a laptop, or if I want to invest addditional time build one. Still got an old case flying around somewhere.

When it “crashes”, what’s happening? Is it just restarting? Or are you getting a blue screen or something?

Besides USB power management issues, the most common error during carve with a GRBL based/USB device is the USB connection is los for a split second due to RF noise / static discharge. Easel may prompt “How did the carve go” part way into the carve.

If you have dust collection setup on your machine, try moving the shop vac or dust collector to a completely separate power source. Sometimes those induction motors will cause a surge to backfeed into the controller disrupting the usb connection.

That’s interesting. I will do so. Thanks!