Computer not connecting to X-Controller

I just finished assembling my new machine and X-Controller. I cannot get my computer to connect to the controller. When I plug in the USB cable a pop up message says “USB Device not Recognized (USB Device Malfunctioned)”. If I go into Device Manager it shows the X-Controller as an “Unknown Device”. On a second computer Device Manager says “Device Descriptor Request Failed”. Can someone please help, it will be difficult for me to call tech support being they are only available M-F. I was really hoping to use my new toy over the weekend. I have tried two computers, one running Windows 10 and one running Windows 7 Pro. I have installed the FTDI drivers and tried Easel 3.3 and 3.2 with no luck.


Did you try more than 1 usb port on the machine? Only 1 port on my laptop works, the others give the error you described.

yes, I tried all four ports, thanks

I found the problem. The USB Bulkhead cable is bad, I temporarily used a USB to USB Mini cable that goes to my camera. Everything linked up and I Carved my first project today.


Make sure to contact Inventables so they’re aware of the problem. Might be more widespread than just you.

Mine found it twice then never again.