Confirm home position not working

Hi, i am having issues with easel homing, if i jog or manually move the machine to work piece starting position, i need to reset the arduino so that it thinks that this is my home position.

i assume the button that says confirm home position is supposed to do this step for me once i have got the cutting head to my starting position.

in machine inspector the DRO dose not set work position once the home position button is pressed,

apart from this everything works well.

i am using aurduino, grbl shield v3, 0.8c

$0=5.000 (x, step/mm)
$1=5.000 (y, step/mm)
$2=25.000 (z, step/mm)
$3=10 (step pulse, usec)
$4=7500.000 (default feed, mm/min)
$5=4000.000 (default seek, mm/min)
$6=96 (step port invert mask, int:01100000)
$7=255 (step idle delay, msec)
$8=150.000 (acceleration, mm/sec^2)
$9=0.100 (junction deviation, mm)
$10=0.050 (arc, mm/segment)
$11=100 (n-arc correction, int)
$12=3 (n-decimals, int)
$13=0 (report inches, bool)
$14=1 (auto start, bool)
$15=0 (invert step enable, bool)
$16=0 (hard limits, bool)
$17=1 (homing cycle, bool)
$18=108 (homing dir invert mask, int:01101100)
$19=500.000 (homing feed, mm/min)
$20=1000.000 (homing seek, mm/min)
$21=100 (homing debounce, msec)
$22=1.000 (homing pull-off, mm)

Did u update easel driver?
Go with the 0.2.7 not .8

1 Like

Hi phantomm, I Beleive I am using 0.2.7, I’ll double check though, I did just update it but it has not worked either way.

Hi Phil, machine home is when I press the home button in the machine menu and it moves towards the limit switches,
Work home is once you set the cutting tip to the corner of your work material, at which point the easel carve work flow prompts you to to set home position or use last save home position,
Both buttons seem to use the machine zero. I.e. If I home the machine to the limit switches or reset the aurdino so the that the machine editor reads x0 z0 y0.

Thanks for your help also it’s greatly appreciated👍

I have just used a spare arduino and installed grbl v9j, and now the machine home and workpiece home now operate as they should,
Just need to transfer all my settings over, one problem iv seen is the limit switches don’t seem to operate the same now, infact not at all. I may just need another couple hours to nut that one out lol.

Thanks guys👍

1 Like