Connecting to X-carve

i try to start my x-carve wiht easel.

But a stay to this page. My x-Carve work because a try with universal GCODE and its work. i mouve all the axis. PLease help me.that’s eight hours I’m disappointed

Do you have Universal G-Code Sender open at the same time? If so you have to close that before Easel can connect. You can’t have them both open at the same time.

yes. its closed and i restard my computer,plug the usb and start the power supply. nothing. same page

We’ve been having this problem with vista/windows 7 users. Engineering is looking into it. The current fix is uninstalling Easel Local and reinstalling version 0.2.2. Try that link, or contact support they can get it to you. You can call 312-775-7009 or you can send them a message.

i dowload 0.2.2 version but easel say me to dowload the next version

After you downloaded it did you double click it to install it on your computer?

If not you need to install it and that message will go away.

I download windows 10 and easel work really good.Thank you for your help

1 Like

I have been having the same issue with Easel not wanting connect to arduino. Yesterday i uninstalled and reinstalled easel local and it worked fine. When i booted back up today for another carve it had the problem again. I tried to adjust some firewall settings and browser settings but eventually decided to uninstall/reinstall easel local again. This time it deleted all of the geometry in the easel project i had open! What a bummer man. Any help on recovery and solving the issue would be appreciated

Edit: From browsing the forums i think i figured out how the geometry was deleted. In my effort to fix the connection problem, i used the ctrl+atl+dlt command to pull up the task manager to check if the easel local service was running. As it turns out, pressing the Windows key+delete has the effect of deleting all the geometry in a given project. I must have hit that combination by accident and then subsequently closed the session of easel before i realized what had happened which removed the possibility of using undo. What purpose could this key combination have that would be more beneficial than detrimental? Very annoying. Lots of work wasted


So I’m having the same problem I think. But Fred’s solution was to download a whole new OS. What’s the actual solution that doesn’t involve downloading windows 10?



What OS are you using?

Try version 0.2.2 since it doesn’t automatically connect.

1 Like

Hey zachkaplan!

Windows 7. It’s fussy. Your pal Hayes helped me out and he was great. It was a windows 7 problem almost entirely (part that wasn’t a windows problem being my own idiocy or carelessness as usual)

The solution was to find a free half hour, call old man Hayes in Chicago, have him help. Done and done. Thanks a bunch!


1 Like

Hey @PaulMLaska I’m sorry you were in this situation. Quite frankly it’s unacceptable. There are no Windows 7 problems or customer problems only Inventables problems. It’s our job to make sure our customers are successful…period. I don’t want anyone getting into that situation. It’s frustrating, it’s not fun, and you aren’t making stuff. We are trying to bring out the maker in all of us not scare it away. :slight_smile:

Old man Hayes is one of our top performers. I’m glad he was able to work it out with you. You can see a picture of old man Hayes here. He is wise beyond his years.

Thank you for your patience while we worked through this issue with you.



Sir Zach,

Honestly, I used the word frustrations when I should have said challenges.

Also I use too many words so it comes off as critical when I’m just trying to be articulate, especially online.

You guys have been great. Keep up the good work!

Anyone else reading this: Zach Kaplan offered me a concession but I declined. Nice guy to offer though, huh? Solid company, kind of a breath of fresh air from the best buys of the world.

1 Like

I have the same problem, coming up to the USB connection and nothing happens.
with win10 that with mac.
it seems there is not even connected usb.
does not even the usual USB connection sound, with both OS
Please help me


I try to remove and install the arduino driver and easel driver

1 Like

Ok, but is like it dosen’t connect the usb…
Now I have installed again the easel driver and the arduino program like the instruction at step 16.


ok, this evening when I come home from work I’ll try a different cable, the one I use is the one provided by inventable.
I installed the Arduino driver following link of the instructions that lead me to the Arduino site, you have a different link? you can shoot me?
However if I can not see the device do I fear it is useless the rest

I skipped this step because the DEWALT that use light it up manually, but I must also connect the yellow and black wires?
because it seems that the Arduino is powered off.
Maybe that’s what I do not see it when I connect USB

Ok, I connect all.
No,when I plug the usb nothing happen.
is how arduino is off, while the other is on.
I have try to feed arduino alone to see if it works