Custom settings for z-axis?

I built my own CNC router based on the MPCNC over on Thingiverse ( http://www.thingiverse.com/thing:724999 ) which works great. Instead of a RAMPS shield, I built mine with a GRBL shield running GRBL 0.9, so I could use it with Easel.

It actually works great with Easel for the most part, except the z-axis doesn’t cut deep enough and it doesn’t pick the bit up high enough when moving to a new cut. My guess is the 12" long 5/16 all thread has a different travel rate than the two default settings provided in machine setup in Easel (because I have tried both with the same results).

Does anyone know if you can set or modify the z-axis settings so I can get accurate cutting depths and no more ruined jobs from the bit doing a shallow cut all the way to the home position?

I just answered this on your other post…

You can adjust the settings by entering a value for $102 (Z-Axis steps per mm)…

This sound like your Z is missing steps as in slipping. Provided your zeroing workflow is correct and the material is fairly even the bit should not hit material during repositioning / return to X/Y zero.

Calibrating the travel is easy enough by recalculating the steps/mm value for the Z-axis.

1 Like

Finally got the z-axis cutting close enough though not exact:
$102=3825.000

What is yor microstepping that seems like alot. Its also going to be slow.

Thanks PhilJohnson. I have tinkered around with the settings for so long now that I have just gotten frustrated. I have since resorted to reducing my designs down in Adobe Illustrator by 80.26% and then bring them into Easel. I will mess with settings at some point in the future, but I need to make things with my router now.