Cut not symmetrical?

Hello, I purchased the X-carve 500mm a few months ago, I am using it to cut eyewear frames of wood, I design everything in Inventor HSM CAM 2017 and use the post processor to generate the g-code and than import that into Easel. However I always have a problem with the Frame not being cut symmetrically, I have calibrated the machine in just about every way I’ve thought possible. I was hoping someone can take my code here:Perimeter (9.8 KB)

and try it on there machine to see if there is no problem, because I am curious if it is a mechanical problem or software issue.

I use left climb milling, but I’ve also tried Right Conventional with a trace path setting. Ive tried various feedrates the latest being 150mm/min. Im new to CNC milling so if this is not what you mean by Cut Settings please let me know. Thanks for your reply, Neil

Also the frame in the picture was cut using Right Conventional, when I use Left Climbing it has the exact opposite results meaning the thickness and thinness are reversed on the frame.

Yeah I know its really slow, I just have been using trial and error in order to see if slowing the cutting rate would make a more accurate cut, but it didn’t make a difference. Currently I’m using a 1mm bit at a .5mm cutting depth and only trying to get the shape to come out correctly on a flat piece wood, but with no real success. I did calibrate my steps, Y-Axis = 40.138 step/mm and X-axis 40.166 step/mm. Do you think its a calibration problem? It isn’t to complex a shape to cut accurately is it?

You want me to share the cad file? Thats no problem. Also as for the tool path simulation in Inventor HSM CAM everything is fine.

Here is the Cad file, should have everything you need, if not let me know. Thanks for the help Phil.

wood frame1.dwg (154.0 KB)

1 Like

Try rotating the object 90 degrees in your cut file. Seeing how the areas of too thick and too thin change (or not) will help you troubleshoot.

But my best guess? It is some kind of backlash error. Probably a pulley just slightly loose. So that it shifts a little when it reverses direction.
If it was missed steps the whole cut would drift.
If it was out of calibration then all the thickness would be off uniformly.

I had this problem and it manifest in different ways depending on the cut strategy I was using.
It is easy to test. With the XC on so the motors are powered, wiggle the gantry while looking at each pulley. You will see it if they slip.


I opened up your Perimeter file in CAMotics (some freeware). Looks like it should cut just fine. The .nc file looks symmetrical.

Maybe try placing the origin at the center of the part? Right now it looks like you have it down and to the left of the part you’re cutting.

Come to think of it… it doesn’t look like it’s cutting it because I should be seeing the material being cut in CAMotics and it’s not being cut. Hmmmm…

For example, here’s pieces I cut out for a sign I made recently… the .nc file shows the tool cutting into the part. Your .nc file doesn’t.

Can you share the file in Easel?

Thanks everyone, Im going to try the suggestions everyone has made and share the results later on today.

1 Like