Cuts Still Not Straight After Calibration

Can’t see photos.

Sorry guys, Here they are!

If it’s due to lost steps, you may have one of a few problems that are easy to correct. The easiest to check, in order, include:

-Loose pulley screws (or pulley screws not centered on the flat on the shaft)
-Belt tension too loose or tight
-Pots turned down too low or up too high

I’m sure there’s others, but those are most of the common causes. There are videos on here (search for maintenance videos) that address the methods I use to check belt tension and pot adjustment.

Robert, thanks for the reply. I tried everything you suggested without success and I thought it might be an Easel problem. Turns out, cutting a circle in Vcarve Desktop, same diameter, etc. causes the same thing to happen but rather than at the 8:00 position as shown in my photos, it’s happening at the 1:00 position in Vcarve using UGS as the gcode sender.

I’m totally at a loss and very frustrated at this point. I have spent the entire day trying to fix this problem and I’m not any further along. Starting to second guess my purchase.

Each one of us went through the process of dialing in their X-Carve, so we understand just how frustrated you are. There’s a good group of people in this forum that jump in and help whenever they can, and Inventables goes above and beyond to take care of their customers.

If you can give us some more information, we may be able to help figure this out. Here’s a list of things that would help us out.

HARDWARE
-What spindle?
-What bit?
-What feed and speed?
-What type of wood?
-What method do you use for belt tension, and what is belt tension set at?
-Is there any wear on the edge of the belts, like you’d get from misaligned rollers?
-Is there any debris collected in the belt teeth or the pulley teeth?
-What other physical troubleshooting have you done?

SOFTWARE
-Since it happened in Easel, can you share the project link?
-Since it also happened in other programs, can you share the files?

OTHER (from photo above)
-What direction was it cutting in for the photo above (clockwise or counterclockwise)?
-Are the inner circles supposed to be offset?
-Of the 4 circles, what order were they cut in?
-Is the cut path any thicker than it should be?
-Did you notice any odd sounds while cutting?
-Did you notice any odd stopping while cutting?

I know it’s a lot of questions, and I’m sure others will have more, but having this information will allow those of us with some experience to be able to come up with some other suggestions.

Before I tried it with the router, I zeroed above the board about 1.5" and ran it without the router running. I’m using a Bosch Colt with the mount purchased from Inventables on a 1000mm machine. When I ran it with the router off, I could see it catching in those positions as well. When I put too much current on the Y axis with the pot, I finally got some grinding and binding. I backed it off a bit during the job (with router off) and it started running smoothly but, again, the crazy jerk in the toolpath was still occurring.

I use shrink tube on the belts and tension them pretty well. They’re snug for the most part and don’t really slip.

After working with the pots and changing current appropriately, I can run straight X and Y axis for 31" across in both directions without any binding, grinding, or missed steps. My cut depths are 0.1" at 30"/min feed rate on a 0.25" end mill.

After going through all of it as you suggested, I did find that the X stepper is missing one of the screws holding the pulley in position on the shaft. Perhaps, that’s the problem. How that backed out and when I have no idea. Where I’m going to find a replacement is an even better question.

Robert,

Oh, I might add, thanks for all your help and suggestions. I will work through the rest of it and here’s the link of this simple circle. I’m trying to cut it on a scrap piece of pine right now.

http://easel.inventables.com/projects/Sz2FVJjgQDun7xI9RCNHjw

@RobertA_Rieke also, this is happening in counterclockwise direction in Easel and clockwise in Vcarve and only appears to be happening in one particular combination of x and y movement directly across from each other if you look at the circle cut above. Also on the lower left of the J photo but nowhere else. Scratching my head and going to sleep on it tonight now.

Thanks again for all of your help.

@AngusMcleod I ran it without material at all and the router turned off and could still see it doing the twitching in the circle cut.

Myself and others on the board have had the exact same thing with circles (exactly the same place on the circles, btw). Stay with it and you will get it dialed in. It’s not software related. Go back through the build section on the belts. Make sure the ends are secured or the belts WILL slip.

My machine runs perfect now. It took me about a week of tweaking and reading. Yours will run great, too.

One thing I learned was, my mechanical intuition was leading me in the exact opposite direction of where I should have been going.

1 Like

If the X pulley is missing a screw, that’s likely the problem. Or one of them. Unless you have a screw that is centered in the flat on the shaft and tightened down, the pulley shaft can rotate a little before the screw catches the pulley. You definitely want to get a replacement screw, but make sure the existing screw is dead-center in the flat, and tight. You may even put a little bit of loctite on, just make sure it’s the loctite that lets you reposition. That problem has come up before, so you can do a forum search for “pulley screw” to find out what size they are if you want to get one locally.

One way to check if the shaft is moving before the pulley is to make a mark on the faces of the shaft and pulley, then move the X carriage back and forth. If the marks ever move apart from each other, you know that’s the problem.

As you found out, you don’t want to have the pots turned up too high. What I did was simulate cutting a 24" line at .001" depth of cut so it would constantly work the steppers. Then I let it run 5-10 minutes, and if there was any indication of overload I would tweak the pot down and restart the 5-10 minute wait. I think I explained that in the pot adjustment video.

Are the catches happening in only one specific location on the table? Or is it when the pulleys are in a specific position? Try running back and forth a few times in X, by hand (slowly) and under power. There may be a divot in the makerslide causing a problem, or damage to one of the V-wheels. You can use pencil to make marks on the makerslide that will come right off, so mark anywhere it catches so you can take a closer look. Then do the same thing with Y.

And definitely search through the ts topics for RobertA_Rieke 's belting suggestions. He got me sorted.

@JDM thanks for the encouragement! I need it right now! Perhaps church in the morning will help.

@RobertA_Rieke you have a pots video? Can you send me the link to it? If you did, I missed it sorry!

Hey katslod, I was having the same problem and just when I was about to sell my machine to my father in law which is dying to buy it from me for a cheaper price, I found the problem. My eccentric nuts were just a bit too tight, almost all of them. Try to loose them up just a tiny bit and see if that solves your issue. Make sure that you can move them with your fingers with a descent force but "not " with too much force. Now the machine cuts perfect circles. I hope that can solve your problem.

I’ve got 4 videos in this thread: X-Carve Maintenance/Troubleshooting Videos - Add Your Own!

Still getting the flaws after going through everything that was suggested. Not sure what to do now, but I’m beyond frustrated. I had it flawless for a couple of days and then it started ruining boards again. Went through everything and tried a practice cut and worked great. About half way through another cut, jumped a step or two and ruined the piece again. So far, I have as much in ruined wood as I do in some of the parts of this thing.

@pike_lake if you’re up for a 20 min drive, I’ll buy lunch if you can take a look or offer suggestions sometime.

How about a night after work this week? I could swing by on my way home. What’s your address? And what would be a good night/time?

I think I found the problem. Two more set screws worked themselves out again. One X and One Z axis. I have now applied Loctite Blue to all the set screws in all 5 pulleys as well as realigned them to be on the flat part of the shaft in the hopes that this solves the problem once and for all.

I’ll keep you posted @pike_lake

That’s great news! Sounds good. Glad it’s working for now. Hopefully this will be the end of it. There’s nothing like getting that first trouble free cut out :slight_smile: But it’s trial and error. I’ve had my system for over half a year and still breaking bits here and there. It’s not a bullet proof system, but I’m not disappointed. It’s made many people around me happy with the stuff it’s produced.

1 Like