Cutting wrong depth

Suddenly my machine began to cut too deep (using Easel). I had done a previous successful run, changed material and instead of cutting the first pass 0.7 mm deep it directly went down to approximatelly 2 mm. Next pass was also 2 mm. Tried once again, same result. I started over with a new design with a simple circle, same result again. I restarted the computer and the gshield and made a new test design, needless to say - just the same.

I have checked everything I can think of. No cables or connections loose. Have also done a new setup.

And material and waste board are dead flat, bit and collet are tight.

Pulley is checked and secure. Besides (without being rude) if it was slipping it would decrease stepping down the X-axis rather than increasing it.


I have examined the pulley and everything is tight and firm.

@PhilJohnson: I haven’t got Loctite but will get that.

Since I can’t find any mecanical issues I’m more into it’s something related to electronics or software.

If it really is no mechanical issue…try a different software platform :slight_smile:

Use Universal G-Code Sender (UGS) and tell the Z-axis to move 5mm up/down.
Does it really move 5mm up or down?

If yes => step/mm is correct
If yes => Easel should do the same, gcode is gcode

If no => how far did it actually move?

I have checked pulleys several times - everything is dead tight.

So I tried Universal G-Code Sender and rigged up a digital caliper stepping down 50 mm, one mm at the time checking the caliper and it worked fine.

I went back to Easel and set to carve a square shaped slot, 1 mm cut per pass. First pass was 2,5 mm, then it took 1 mm at each pass, down to 10 mm. So it seems to be just the initial pass that’s to deep. Of course I have calibrated the Z zero. Even if I hade missed by some 1/10th of a mm it shouldn’t cut 2,5 to start with.

And I have also tried another computer.

Are you probing Z or manually setting Z?

If probing, ensure the Z probe thickness is set properly in Easel. That could be throwing it off, especially if you re-ran the setup.

No, material is absolutelly flat and firm to the waste board.

I disassembled the pulleys and couldn’t see anything that was wrong. Also checked V-wheels.

I made a new test in Easel and noticed one thing that might indicate it’s not a mecanical issue. I set it to cut 8 mm (1 mm per pass). First pass it cut 2.21 mm and then the progress bar in Easel already showed 48% done. Then it cut 1 mm per pass to 100%.

What was the ending depth? 8mm or 9.21?

Odd; 7.6 mm.

Here is the G-code:

G1 Z3.810 F228.6
G0 X75.000 Y75.000
G1 Z-0.711 F228.6
G1 X25.000 Y75.000 F762.0
G1 X25.000 Y25.000 F762.0
G1 X75.000 Y25.000 F762.0
G1 X75.000 Y75.000 F762.0
G1 Z-1.422 F228.6
G1 X25.000 Y75.000 F762.0
G1 X25.000 Y25.000 F762.0
G1 X75.000 Y25.000 F762.0
G1 X75.000 Y75.000 F762.0

The gcode says Z begin at 3,8mm (default Easel Safety Height)
First pass is at 0,711mm below surface.
Second pass is at 1,422mm below surface.

Gcode do not explain the behaviour you are experiencing.
This indicate mechanical error or elsewhere within the mechanical chain/system.

1 Like

Thanks. I have checked all plausible mechanic parts and I’m beginning to get frustrated.

However, hate to say you are wrong but one fact remains: after cutting the first too deep pass the progress bar is approximatelly halfway, then when cutting the passes 1 mm at the time the progress is more accurate.

Besides, it worked fine with UGS, even when I simulated load on the spindle.

Yesterday I made a batch of, eight of them and progress bar stepped one percent at the time. The problem occured when I ran the nineth one - and bam - the progress bar rushes away during first pass. I can understand it isn’t totally precise but this is strange. I’m definatelly sure as I were keeping an eye on router and progress bar.

And remember, even if the first pass is too deep the rest are stepped down 1 mm at the time with acceptable tolerances. I almost wish they weren’t.

As I mentioned earlier: wasteboard flat, material not warped, firmly tightened. All dead tight.

I have checked every part in Z. No slope in delrin nut. Nothing moves when I press the spindle hard up and down, except from “normal” flexing in the maker slide. All screws tight.

Of course I trust your experience and I’m glad you are willing to help but and I really wish I could find something mechanical. I can check the pulleys a 34th time but it won’t help.

And right, I’m going away for early Christmas celebration and will be back on Tuesday. Hopefully new perspectives then.

Yepp. Never believed in aliens but will from now on. :smiley:

I was in the same boat last week too . Not mechanical , not the waste board . Carving acrylic sheets. 1st cut was fine , 2nd cut was down 1.5 mm lower than expected . Blue Loctite was done last January , belts are tight, all nuts and screws tight , wires checked , Motor checked for voltage , Still doing it .

Not the first time it’s happened . I’ve gone through 4 boards in the last 11 months . Will check another avenue later tomorrow .

Not saying it was going to fix itself at all . Just said it’s frustrating when it keeps doing the same thing over and over again . No real answer or reason for it . When I get some time to devote to it I will .

Gcode is perfect . Cutting acrylic with a down flute bit . Have tried different bits too . Last time this happened in June , the arduino board was and went bad . New boards fixed problem immediately . Very frustrating .

I’m facing the same problem … A few months ago this problem started …

I tried everything.
I completely disbanded and rebuilt the mechanism

Testing the time when the z axis will be shifted to 5 mm it will move 5 mm. But the final result of the work is 5.4 mm

Did you solve the problem?