Default Picsender to Incremental

Is there a way to default picsender to use incremental mode? Also, is there a reason to use absolute mode? I have snapped several bits by forgetting which mode it is in.

Thanks in advance.

When PicSender connects to the com port it should be automaticly setting grbl to incremental (G91) jogging mode.


You can also set a startup block for the jogging mode by typing in $N0=G91 in the Do Cmd. and then execute it. It will set it to G91 every time you connect to the com port too.


Typically my workflow (and this might be my problem) I start pic sender. It connect, but I can’t jog my x-carve until I hit $X - Kill Alarm Clock. That is when it goes to ABS mode. Or is this me being a complete and total newb?

If you don’t use Homing and it’s disabled ($22=0), you don’t need to kill the Alarm to jog. If Homing is enabled ($22=1) you should Home your machine before any jogging.


Typically I use the Triquetra zeroing block for all cuts when I use pic sender. Should I look at turning off home by default if it is enabled?

(Thanks so much for your time in answering my questions)

If you do not want to Home your machine, disable it in grbl ($22=0) with the Do Cmd, close the com port in PicSender, reconnect and jog to the starting position for using the zeroing block, load & run your tool zeroing gcode file and then you can jog where you wish from there.

1 Like