Delay in x carve response

X-cave seems to respond slowly to jogging and carving. Projects take 4 times longer than Easel calculates. Had my machine for 8 months, problem started about a month ago. I use Easel for all my projects. An ideas?

Can you get the machines grbl settings and post them here?

Go to machine inspector by pressing ctrl+shift+D and scroll to the bottom of that page to see the settings.

Another issue could be a reduced baud rate of the usb port. You can go to Device Manager in windows and check the properties if comport (it’ll be in the section labeled “PORTS”)
The baud rate should be 115,200