Delay When Jogging

I have a strange problem when jogging my machine (4x4 XCP) using the on-screen controls. It doesn’t matter if I’m using Easel or G-Sender. When I click + or - on any of the axes the machine doesn’t move until I move the mouse away from where I am clicking. Sometimes it will even send a constant move command instead of one click. As soon as I move my mouse cursor away from the button I just clicked on, it sends the command. It even does it when I click to start a carving job. As soon as I move my mouse away from the button, it sends the command. Has anyone else seen this problem? Could I have setup something wrong?

Thanks,

Jonathan

Click lock may be enabled and set to extremely short period… Check you mouse settings.
Press the windows button, type “mouse settings”
then here, click the advanced settings and verify this click lock function is not enabled.

IF this doesn’t work try another mouse or the touchpad buttons if this is a laptop.
If you are using a hand held mouse you may also want to change the batteries and update the driver.
But since this is doing this across 2 programs, this sounds more like a settings or device issue than one with the machine or either program,…

adding to @SethCNC - in Easel does the problem occur when using the arrow buttons on the keyboard? This would confirm whether the issue is with the mouse or elsewhere.

1 Like

Seth,

I will try a different laptop after work today to see if this fixes my problem. Could this be related to the baud rate change being different than the grbl standard?

1 Like

James,

To be honest I don’t believe I have tried using the arrow keys. I’ll try this today. I’m also going to try another laptop to eliminate that all together.

1 Like

Sounds like you might be due for a restart as well.

1 Like

I really doubt it. the delay of the baud rate for a single jog command would go unnoticed. The slower baud rate really only becomes and issue when the CNC executes short movements in rapid succession and depletes the gcode que before the que can refill as a result of the slower baud not filling it faster than the cnc executes the commands. In theory this would cause a bit of a jerky movement of the cnc as it pauses and waits for the que to receive more lines of gcode to move again and dies this move>pause>move>pause thing repeating.
—However, I should note that I’ve only actually seen this cause/effect in action on 3d printers since the 3d models use tons of tiny flat faces causing millions of direction changes in rapid succession.

Switched to a different laptop and the problem appears to have cleared up. Glad to see it wasn’t something more than that.

I also tried again on the other laptop and still had the issue. I updated the BIOS firmware on the laptop and that seemed to fix it.

Last Edit: It turns out is wasn’t my BIOS, it was the trackpad on the laptop. The problem came back shortly after I updated the BIOS. I started using an external mouse and the problem cleared up.