"Depth-first" carving for text and smarter "outline" grouping

I used Easel yesterday and noticed that Easel was completing cutting of each shape before moving on to the next. This appears to be a major improvement over the layer by layer approach. Thanks!

I would very much like to be able to use the separate roughing, finishing cut process. Will this soon be incorporated into Easel for every user?

1 Like

@PeterWilkens, if you would like to “Early Access” that feature, you could request it here: Two stage cuts

Finally got around to testing the text following these changes and sure enough it’s a lot faster carving now. Still a few odd Z ups and downs but seems much more optimised. Excellent. :smile:



1 Like

I understand that this is an old topic but I am not sure where else to ask it. Sorry for my apparent ignorance - I have not been using Easel much. Is this an ‘on demand’ feature? My letter carves still go by 'layer by layer"?

Periodically I am having my projects carve layer by layer vs. object by object. Very annoying as it adds so much time to the project. I contacted Inventables and was given no assistance.

Hi @KeithTromans,
No this is not an on demand feature.
Could you share your project please?
You can follow the menu, File->Share->Shared with Link.

Hi @JosephCompton,

Could you please share your project as well? It would help me a lot to find and fix the problem.

Thank you


@Ruwan If you can access my account you can check any of the projects you want, but I don’t want to share the file publicly. But the bug is not limited to one project or even consistent. One day it will cut normally, the next it will do the cut layer by layer, so it’s not something necessarily within the project as it is not consistently bad. I can even create a new, very simply project right in Easel and it will have the same problem.

I am also, having issues with the USB connecting, where I often have to unplug and replug the cable multiple times to get the controller and my computer to communicate, and it seems like this issue may be connected. At these times even when I have a connection I will have a slow response from the controller, where there will be a long latency between the command from my computer and the action taking place at the router.

@JosephCompton, I understand. I’ve checked your most recent 5 projects or so and simulated the toolpaths and did not find any issues. But If there an issue, I would like to find and fix it ASAP.
So could you please let me know whether you noticed this layer-by-layer issue about one week earlier? If so we fixed a layer-by-layer issue on last Monday (Jan 25, 2016).

Just to clarify, when it does layer-by-layer, do you see the tool raising and lowering (in z-axis) between shapes?

Hi @KeithTromans,

I checked your project and found the reason why your letters are done layer-by-layer. Given, some of your letters are connected, they are considered as a single object, and carved layer-by-layer. Those two letters that are not connected to the rest are done object-by-object (a.k.a depth-first).

Please let me know if you need more information on that.

Thank you


Thanks for looking into this @Ruwan.

I am aware of how connected objects would cut as a unit and that’s not the problem I’m seeing. The last time I had the issue was sometime late last week, either Thursday or Friday and the projects I was using was “Calendar.” This is a bunch of holes and boxes, which are not connected. When cutting it would take a single pass on one hole, the z would raise, move to another hole, take off a single DOC, move again, and so on. Going through all of the holes at one depth, and then start over taking off the next depth. The project does finish correctly, but the extra traveling makes it take significantly longer. It operated this way for several jobs that day, but then the next day I ran the same project and it worked fine. And I don’t modify the project between cuts except to select different objects for different cut depths, it took a lot of work to line everything up properly.

I’m sorry I have to describe this, I tried to load a video, but have not been able to upload directly on the forum and I don’t want to set up a YouTube account.

I run my x-carve daily so if I have the issue again I can let you know right away. I did contact Customer Service a week or so ago, but he just said that he would mention it the developers, so.

1 Like

Thanks @JosephCompton for the detailed reply. I will look at the “Calendar” project and also any changes we did around Thursday and Friday. If I find something I will let you know. Also as you said, please let us know if you experience the problem again. About the video, that is totally fine, you explained it well.

Hi Ruwan, thanks for taking the trouble to find my project and provide the answer. One other question: on the same project I got the “use a smaller bit or make the font bigger” message - even with the 1/16" bit. So, I tried the 1/32 bit I had. It broke immediately. With the 1/16" bit the tails of the serifs were not cut. How can I carve this properly? Bigger is not an option.

@KeithTromans, sorry to hear about the broken bit.

Please check the red region in the 3D viewer. Easel couldn’t reach those regions with current tool size. If the red region is relatively small, you could ignore the warning and carve the project.

Easel shows that warning if the topology of the text is not preserved or 20% of the area is lost due to toolsize.

Hope this helps