Depth of cut issues with z axis

I’m having issues with the x-carve accurately cutting the depth that has been set and designed in Easel.

For example, in a recent cut, I had the depth set to .25 inches in Easel to do a full cutout of the workpiece but after several trial and error attempts, I needed to set the depth of cut to about .14 inches which was creating a complete cut through the workpiece but didn’t allow for the hold tabs to be cut because the carving didn’t think it was far enough down to start to cut those.

I do use custom cutting settings for a .047 inch diameter upcut end mill bit to go more conservative than the default settings. I generally half the depth per pass value and slow the feed rate. I’m wondering if it is these custom cut settings that are somehow causing the issue.

My set up is:
1000x1000 machine
Dewalt 611 router
arduin + gsheild controller
Easel driver 03.17 for Windows


Calibrate your steps/mm for the Z axis.
Measure the thickness of your material.
Check grub screws on the Z screw pulley and make sure they have the pulley secured to the acme screw.
Typically when these are loose it will carve too deep.