Desperate Need of Help!

I am hoping someone here might be able to sort me out …
I can’t figure out what is wrong with my machine.
It was working fine, then one morning it decided to stop working and started to carve in random spots.
So I replaced the gShield, and the Arduino. While I was doing that, I thought it best to rewire the machine as it was a second hand one I had purchased. Reset the pots and everything seems fine.
So rewired and updated software and Arduino settings checked. Start the machine, still the same issue.
Tested the motors, couldn’t find an issue with them, but decided best practice, replace them to take that out of the equation. So new motors purchased and installed.
Restart the machine, same issue.
Maybe the power supply is faulty ??? Purchased and replaced the power supply.
Restart the machine and same issue.
I don’t know what else to try.
I thought I had everything all sorted, but maybe I was wrong, well lets face it, no one else is having the issues, so must be me.
I have a video of the machine running a simple box pattern from the inside out, and you can see the LEDs run fine, then drop out. Not sure if thats normal, but I can’t think of anything else to say or show to try and get it back up and running. I have already lost hundreds of dollars in orders cause I can’t get stuff done, so I am now desperate to get it sorted… I don;t know of anyone in Australia that might have the knowledge to help me out, so if anyone knows “a guy”, please let me know…
If anyone has any suggestions, I assure you I am all ears. I am not electrical minded, but am willing to try anything…

It didn’t upload the video cause its a little large … I will see if I can make it a bit smaller and repost it …

1 Like

upload to youtube, then post a link

Sorry the video is so long …
I had to film it till you get an idea of what it is doing.
So it does one pass, and the second pass is 10mm out.
So dropping the Axis is apparent, just not sure how to fix it …

I think showing the actual machine in action and/or pictures of the project and the results would be more help.
Are your belts and pulley set screws tight?

Yes, film the machine (with spindle off) actually moving / attempting to move :slight_smile:

Random movement is 99% related to mechanic, improper speed settings, underpowered motors.
Code is just code and rarely the culprit.

Yeah, I tightened the belts and rechecked them all after a pass or two.
So, when your machines are active, do the LEDs do something similar, or is that just my machine ???
Are there any other tests I can do to narrow the field down a bit ???

I am using Fusion 360, so the speeds and feeds are what ever they suggest …
I couldn’t find any relevant info for said parameters on cutting Australian Radiata Pine, so I just left what was there. I was cutting random motifs originally, but now I want to try and get some more accurate things done, I am finding that it never seems to return to home after a cut pass… It is always a fair bit out. So when I run the second pass, it is in a different position.
I have tried to adjust the pots like the advice on here somewhere, and then I tied to wind it up and down minute amounts to see if that might fix the issue. No joy…

Also, do a search on calibration.

This is a clear indicator of missing steps somewhere during the carve.
I suggest for trouble shooting that you only use a simple shape designed in Easel, using Easel as your sender to avoid 3rd part DAC/CAM & PostProcessor issues. ( I use F360 aswell)

I suspsect underpowered/sized motors / incapable drivers for what they are asked for.
What motors do you have and what current is the drivers limited to?

1 Like

Overheating the stepper drivers may be a cause as well. There’s a good video showing how to calibrate them or you can use a meter and measure the voltage level that the pots are setting. I think Larry had a post on that somewhere.

Hey Aaron, before you check calibration and all that (which you should definitely do), make sure the Arduino is properly seated on its connectors to the other board. Mine wasn’t… That was my first lesson and drove me crazy for a week or two. I hope it’s as easy as that. Good luck!

As already stated above, You should start using Easel’s feeds and speeds.
Fusion 360’s defaults don’t mean much…

Start with Easel. Carve a square. Some lines and circles.
Easy to predict and measure objects…
Start small.
Is the problem when the machines moves X, or moves in Y? Etc etc…

Stepper motors can only move so fast.
If you try to move the steppers to fast, they will hum and stall regardless of the GSHEILD’s pot and power settings.
What are your GRBL settings?

It sounds like you have changed out just about everything. :frowning:
A bit of brainstorming here…

Did you take the fan off your controller for the video? It needs the fan for cooling. Overheating driver chips could be a issue.

As far as testing goes, try air cutting (no bit) a carve you know has issues.
By air cutting you are taking the load off the mechanicals, so if it air cuts fine then you probably have a mechanical issue somewhere.
(Flip your bets over and check for squished teeth - I had that problem and it took me a bit to figure out)

If it still fails, try air cutting again with the router off. Just in case the router is causing some kind of interference. (I don’t know of an issue with the actual routers, but the old spindle motors would cause all kinds of weirdness as they started to go bad.)

It could be a USB issue too. A bad cable or connection issues.
One laptop I had would work fine, the other would drop usb connection every time the dust collector would power off. Using a powered hub fixed my problem.

Next thing would be to post your settings/grbl output here.

Yep. In my experience fusion stock settings would be far too aggressive in every way for an xcarve

Ok Guys - I have taken everything onboard and tried a bunch of things …
Like I said I am new to all of this and in no way an electric wizz, so I checked all the connections, I found 2 that were a little loose, but still connected, so I fixed those as best I know how …
I ran a project that I know worked prior.
Got the tension all sorted on the belts, they were a little tight according to the set up people said i should watch for ideas…
So this is the current outcome …
You can see where it ends up after a carve, in a different position both X and Y. (I also attached a pic of what it was like before the new issues showed up.
I have checked the screw settings on the Drives, and reapplied the loctite. So its getting closer now… After reading things, I might get some new belts to make sure that isn’t an issue. It was a second hand machine to start with, and the belts are 100%, but never having seen a new one, I am not sure how worn they are.

That’s what it is. Like Robert saying. You should of start replacing from your spindle instead. Stock spindle gives this symptom. You must upgrade it to Dewalt or something like Makita or VFD controlled spindle. That is your problem.

Before you do anything else, check the pulleys on your motors. I had the same thing happen to me until I put blue loctite in all of the pulley set screws. No matter how tight you get them without it, they will eventually work themselves out I found.

Make sure at least one set screw is on the flat part of the motor shaft as well. I was shocked that the blue loctite was the solution, but it was.

@AaronJames have you tried this yet?