DeWalt 611 Non-destruct Automatic Spindle Control

Figures…I paid full price a couple of weeks ago :smile:

:laughing: I’ve had it on my wish list since this thread popped up but I’ve been too preoccupied to do anything with it. Jumped on it tonight when I saw that.

1 Like

Works well. I like it and thank you all for finding it and discussing how to use it!

So 2 quick question. 1st this relay is to control power to router right. And second the yellow and black wire controls what. I’ve decided to skip the homing switches. Which means I really wouldn’t need to solder on to the g shield, I’m running Dewalt router. Newbie here

Wow, that looks very organized, looks power plant. I’m sure you’re planning to put some dust cover on top. Great job.

1 Like

AlanDavis and PikeLake had the outstanding intro and feedback on the box. The relay controls the router power on/off essentially. I set the speed on the router. I have not tried to determine if I could control the speed with the box at all. In my case, I have the yellow and black cords running to both the power relay and the gshield pins. Essentially copying this photo:


This is awesome! I do have a question though. I am using a TB6560 control board and will be using Mach 3 with a DWP611… will this product work for me given my setup? Thank you

1 Like

I bought this relay in anticipation of my X-Carve. I finally did my machine setup yesterday and this worked beautifully. Thanks for this!


@WilliamJames I’m not sure. I’m using Easel straight up on a Mac. Plug and play :slight_smile:

@pike_lake Cheers :slight_smile:

1 Like

@pike_lake - have you used this relay to power on your spindle via UGC? Mine powers on if I flip the spindle switch on the power supply to the on position, but in the logic position, my 611 doesn’t power up - I’ve got it wired just like in your first picture. (for some reason I can’t connect to my machine via Easel - Inventables Tech Support couldn’t figure out why though)

To turn mine on I have to send an M04 command and for off an M03.

Little odd, but it works.

@ErikJenkins I’m REALLY new to this (like, tech support got me rolling this morning). I assume the M04 and M03 get edited into the gcode before it’s brought into UGC? I tried that and it doesn’t turn my 611 on.

try to type in the commands in UGS and see what happens.

make sure it works for you before adding it into a gcode file

try to turn it on with an M03 command

I tried the M03 command in UGS - it returns with OK, but the 611 doesn’t start up.

Try M04, mine doesn’t start with M03 either

Stupid fat thumb…I meant M04 doesn’t start it (but neither does M03, for that matter)

Check your wiring, make sure the switch is on logic…

Also verify that you are using the correct pin on the arduino.