DeWalt 611 Non-destruct Automatic Spindle Control

The yellow wire in the picture (Logic) goes to pin 11. The black wire (ground) goes to pin GND.

Make sure your header starts on the first pin (pin 8).

Sorry…black wire (ground) goes to the gnd pin…

Yeah - that’s the way I have it all wired.

Switch on the relay to reset?

Put the dewalt switch to on?

Send M04 or M03 and try it again

It is the switch on the dewalt? Has to be at the on position for the relay to work…I bet that is why it didn’t work. I should have mentioned that first.

Yeah - Dewalt switch was on & relay switch was lit up. I’ll give it a try again later. Starting to move it from the kitchen table to its permanent home.

Possible solution; Turn your Dewalt switch on, check if red power led is on on the relay box, turn your toggle switch manually on (not logic) from power supply. Is your green light on relay box lit? if yes, problem is either Dewalt router or Relay in the relay box is not functioning. If No, Power supply interface not turning 24V output. Because Toggle Manual on bypass GShield operation. Possible solution, Remove front face and interface board in front of Power supply and inspect for and crack solder or any hot spot or something noticeably wrong. Don’t blame Arduino or GShield.

BEFORE all these; Take your Dewalt plug, plug it to wall plug directly. Just check to see if it works. Something is wrong here.

Has there been any update on this? My relay arrived from Amazon today. I already had the Black/Yellow wires installed from Spindle Logic to Pins 11 and Ground and I am only able to get the spindle to turn on if I manually switch the spindle switch to ON.

I also tried sending M03 and M04 to UGS and neither turned the spindle on.

Is there another GRBL change required or something?

My Spindle is also set to ON and it (Dewalt 611) is plugged into the Normally OFF position and both the RED and GREEN LEDs are on on the relay

Try S12000M3 or separately. I have had success with the command of ‘S12000’ alone but I believe it should also include the M3. Type ‘S0’ when you want it to stop

So, using UGS. S12000M3 did turn it on. However I can’t find any combination to turn it off.

Also, how would this work with Easel?

Edit: s1200m5 stopped it. then i was able to start it with just m3 and stop with just m5?

EDIT. In Easel, it seems I can go to Machine>RPM and change it to 0 or 12000 (previously was just set to 1) and then it appears to work.

Is there a way to lock this 0 or 12000 as a setting in Easel?

Interesting result. I have had some pretty good success with Easel and the automatic on/off. I let Easel run the auto set up and set it up for automatic spindle and that seemed to be enough to get it to start up. The ‘S0’ didn’t stop it for you with UGS? I won’t be able to run mine much for the next couple of days but I can try to run further tests to see what was specifically working and not working. V/R J.R.

M03 enables spindle.
M03 S [value] sets the RPM.
M05 disables spindle.

If you are using a PWM supported spindle connected to the PWM pin/port on your then the S [value] will adjust the RPM. If you using the spindle enable pin (no PWM- just on) a simple M03 will turn on the spindle. And in either config. M05 will shut it down.

Oh and M04 is Spindle on CCW. I don’t think the stock DC spindle supports this- But VFD’s do.

Will this work With Vectric Aspire Software also?

It has been working with V-carve software so I suspect it would work with Aspire also.

This works for me… mostly. I noticed the relay pulses about every second or two it flashes off and back on. I’ll try recutting and tinning my wires to make sure I’m getting a good connection, but I was wondering if anyone else using this power relay had this issue.

If you’re using Easel, you have to raise spindle RPM, if it’s UGS or any other G Code sender, you better search this forum for raising Spindle RPM. Might help. Higher the RPM on easel you get higher DC output.

I’ll give that a shot. I think the rpm was set to “1”.