Did I Fry a motor?

So I’m stumped.
The last time I used my XCarve, everything was working fine. However, I never have been able to run it as fast as some others have indicated. My suspicion was my power supply as I was using a 19.5V laptop supply. I’ve got Nema 23 motors, but not the ones from Inventables. Anyway I finally upgraded the power supply to a high quality 350W 24V supply. Since I’m using a Dewalt router, this amount of available power is overkill. I got the new supply hooked up and did a quick movement test and it was fine. Then I got busy with auto repairs and it has sat for a month.

Tuesday of this week when I tried to run it, the Z axis was really working strangely. I adjusted the current pots and it seemed OK. Left power on as I mounted my workpiece then tried to zero the machine. X and Y were fine, but Z wouldn’t move at all. The entire top bracket was uncomfortably hot. As I still had more auto repairs (darn kids and used vehicles!) I simply shut the stepper power off and left it sit.

Tonight I started troubleshooting and can’t get Z motor to turn at all. I’ve taken the Z axis belt off so the motor only has itself to turn and it only hums/growls when I try to move it. Worried about the GShield drivers, I swapped the Y and Z axis wires at the Shield. The Z axis driver will run the machine all over the place so the GShield appears to be fine. The Y axis wouldn’t turn the Z motor then. Finally, I checked continuity and neither phase is open, nor are they shorted together. I didn’t get detailed on resistance of the phases but am wondering if somehow I burned up the motor just sitting there? That really surprises me as I thought the motors had more capability than the drivers. What else am I missing?


Sounds like you may have a short in your z axis wiring. Check all the connections to be sure they are all correct and there is not a stand of wire from one wire touching where it shouldn’t

I agree, a short in the wiring is more likely than a cooked motor. If you’d gotten the motor hot enough to damage it, you would smell it.

1 Like

Today I checked with some of the electronics repair people at work and they have seen motors fail due to heat. Usually the solder starts breaking down and get poor connectors. I completely disconnected the motor and took a better resistance reading and found the 2 windings varied by a factor of 2 so something was certainly wrong.

I then pulled the motor completely off the machine and realized that it had gotten very difficult to turn. With the gear off, I can’t even turn the motor by hand at all. Not sure why it is hung up as I pulled the end plates off and the bearing spin just fine, but I can’t turn the rotor. I haven’t pulled the rotor out as that apparently messes up the magnetics and reduces to power the motor can provide.

I’ll be ordering a new set of slightly more powerful motors and hope to have them early next week and I’ll see how it goes. Since my machine has always been slower than factory settings, I want to replace everything and see how that impacts the operation of the equipment. I’ll send a (hopefully) final update once I get the new motors installed.


I got new stepper motors in yesterday and installed last night. Instantly resolved the Z axis movement issue. It seemed to run WAY smoother than it ever had. I went ahead and swapped all the motors and again initial impression is that things are smoother. I guess I shouldn’t have went with surplus motors the first time… I’ll get things calibrated again today and hopefully am up and running better than before.