Did I Fry Either my Gshield or Arduino? {Resolved by buying a new computer!}

As may be noted by my many questions on these boards, I have had a number of issues. I have yet to get a repeatable (or even any) carve from my machine, but, for whatever reason, I have not given up hope. I finally took a bunch of my machine apart (original 1000x1000 x-carve), tweaked nuts, loc-tited the crap out of everything, did all kind of tests and runs to really dial in my pots, etc., etc., etc. Let’s just say that the mechanical parts have been fine-tuned to death. (Apparently my death, moreso than the x-carve, but I digress).

In putting the top back on my power supply after tweaking the pots a second time, I inadvertently pulled out two wires on the Y-controller on the g-shield, so I patiently got those little buggers back in and went to turn everything on to start some tests on some wood now that everything was ready. And the universe laughs.

No. Of course not. Now my USB cable will not communicate with the power supply. It would appear by this photo that the Arduino is getting power from the computer, so one would think that the USB cable is working.

However, the first thing that I noticed was that I didn’t get the Windows 10 chime when I plugged in the USB cable. Nor did I get the disconnect chime when I unplugged it to try it in a different USB port on my computer. Prior to today, I would always get the notification chimes from my computer that it had, indeed, found something connected via USB.

Here is what I have tried:

  • Replaced the cable
  • Tried a different USB item in the port on the computer to make sure that the port on the computer hadn’t gone bad
  • Rebooted the computer (someone was going to ask that, I’m sure)
  • Installed the Arduino update
  • Installed the Easel update
  • Tried to go through the machine installation within Easel (but it cannot find anything since it doesn’t seem to recognize the USB device)

I am wondering if I fried something - either an entire card (Arduino or g-shield) or I have somehow broken the USB connector at the Ardunio board. I have read some people on the board who have suggested a powered USB connection, but I didn’t have one of those before, so while that might be an addition down the line, it wouldn’t be the cause of it not working now.

Let me just say that I know nothing about sending commands to the Arduino/g-shield; I have only been using Easel to communicate with the system, so if you ask me to try something that requires sending code directly to the system, you’ll have to give me baby steps.

If I DID fry something, I guess I should bite the bullet and get the upgrade kit. Which, since I just spent DAYS dialing in my nuts and bolts and voltages will just make me even more BITTER AND ANNOYED than I already am (and that’s saying a lot).

I know I’m verbose. Let me know if there’s something that I didn’t say that would be helpful.

My suggestions:

  1. push the reset button and make sure it actually works. It might be held in reset which makes it not work well.

  2. take the Arduino out of the enclosure and try it either on a ESD bag or like a cardboard box. The Gshield should not dictate whether or not the Arduino is seen by the computer.

  3. see if the Arduino IDE recognizes the device at all. Might need a reflash.

It sounds like your USB serial chip may be the issue. You can get just a replacement Arduino or, if you want to upgrade, the Xcontroller is available by itself without the other parts of the upgrade kit.

You didn’t mentioned Susan. While doing this take a part, did you pull Gshield from Arduino?
Sometimes if you can’t find correct pins goes to Arduino you get weird problems.
Powered USB hub only eliminates large file transfer buffer problems if your computer’s USB port is not strong enough. At least you can connect without it.
USB connector on Arduino is very strong, not easy to brake.
Try reconnecting your Gshield to Arduino by using flash light first to see what happens.

Do not use an ESD bag!
Its conductive! and you could damage the boards.

First off you need to determine if the driver failed on your system. Try a different computer to see if the arduino is recognized. You can see it in the device manager.

if it works on another system then its not the Arduino or gshield. If it does not then you will need to try a different arduino board if available. If not then order one. They are not that expensive and it helps to have a spare if you need it.

If you fried the boards you would have noticed smoke or a funny burning smell.
Static damage however does not leave any burnt signs or smells and the serial chip could have failed with no visible signs.

Without testing the boards on a separate computer it will be difficult to determine if the serial chip is in fact bad on the Arduino.

I had to take a 24 hour break in order to make a last minute Halloween costume for my son (a giant traffic cone - he loves being inanimate objects for some reason) so I took that time to order a new Arduino board from Amazon Prime which should be here today. I figured for the $23 it was worth trying a replacement since my gut just keeps telling me that it’s the USB connection on the Arduino.

I do know that the USB port on the computer works (thus I don’t think it’s a driver issue). I did take the gshield off of the Arduino, but I felt like I had it seated correctly. I haven’t had time to hook up the Arduino by itself to another computer since I was busy, but I figure that as soon as the new board is delivered I’ll just swap it out and see what happens.

I’ll keep you all posted - thanks for your replies.

1 Like

I HAVE LITERALLY DONE EVERYTHING THAT I CAN.

The Arduino card came. I installed it. Bingo - I was once again getting the connect and disconnect sound from the USB. But did that solve my problem? No. So I dug deeper.

I reinstalled my arduino drivers. I reinstalled the easel drivers. I figured out how to open device manager to see that, yes, my arduino card IS recognized, but is on COM5. Went into Easel and changed to COM5. Still nothing. Read about the baud rate issue. Set the baud rate to 115200. I removed the Arduino and g-shield cards and mated them together outside of the housing so that I know the pins are correctly situated. Then for good measure, I rebooted the computer. Then, of course, it wanted to update (Windows 10). Spent HOURS updating. Literally hours. I cooked and ate dinner and it still wasn’t done. Finally, once the update was done and I had been reading MORE about similar issues, I saw that people talked about reverting Easel local back to 2.2. Went to the downloads page and saw that there was actually a NEWER version (3.1) than Easel had prompted me to download the other day (which was 2.7) so I decided to try the 3.1 version first thinking that maybe that would cure the problems that people were having with connections. Nope. So then I reloaded version 2.2. Now Easel won’t even recognize 2.2 as a driver and keeps telling me to change to the newest driver (which isn’t even the newest - it wants me to re-install 2.7 when I know that Easel is up to 3.1).

To reiterate, this computer and machine were talking to one another just the other day. The prior problems that I was having were mechanical, not electrical. While tightening things up and calibrating the machine, I accidentally pulled out some wires to the Y-axis on the gshield card (which I re-attached) and after that, everything has gone south in the biggest way possible.

I don’t even know what to do anymore, but I am BEYOND FRUSTRATED. Tech support won’t be open until Monday. I am so done.

Did you upload the GRBL firmware to the Arduino?
If not then you will need to follow the steps here.

https://inventables.desk.com/customer/portal/articles/2069033-grbl

Will having already drunk half a bottle of wine improve or hinder this task?

I downloaded the .hex file from the link you sent. Then I downloaded the Xloader program. From what I could ascertain, I start the XLoader program, point it to the .hex file, choose the device (UNO) tell it the baud rate and COM port number and then hit upload (all of which I did). Went back into Easel and no dice. Do I now have to reinstall the Arduino driver again?

I once herd someone say never let anyone code drunk but they never said anything about uploading firmware.

But you may want to remove the hammers and knives from your general proximity :slight_smile:

Done, see reply above. Still in a murderous mood with this thing.

When everything goes to hell, the best plan of action is to reduce the problem to the lowest common denominator and then work your way back up.

I would suggest that you disconnect the gShield from the Arduino and hook up the USB cable to power the Arduino (leave the 24 volt power supply off as it only powers the stepper motors and fan). Run the Arduino IDE and bring up the serial monitor to see if your computer can connect to the Arduino.

Read through this thread and if you understand it then see if your computer will talk to grbl.


If not, post back and I’ll try to get you through it.

Was writing a reply but Larry beat me to it.

I used Arduino Serial Monitor IDE to attempt/verify comm with arduino through USB. It was set to COM3… error opening serial port. I reset the USB to COM5… error opening serial port with Serial Monitor IDE.
So, what’s next (left) to try?

Go to the device manager in Windows and check the ports to see if the Arduino is listed there. If it’s there right click on it and look at the Properties. Check the port settings tab. Baud rate should be 115200 8 data bits parity none stop bits 1 Flow control none

Also is that with the gshield attached? Try it without. Could be that there is a short on the gshield that is causing the fuse on the motherboards USB port to Trip

It is listed and is (currently) on COM5. I also tried setting it to COM3 and no luck opening the port there, either. So am back to COM5. All of the other settings are like you note.

Attempted to use Xloader again just to see if it was seeing the Arduino and now it says that the port isn’t open. So I may just shut it all down tonight and try restart in the morning.

Ok. I’ll check back later.

Closed Arduino IDE and everything else. Unplugged and replugged the USB for the Arduino. Double-checked he USB params.
Tried XLoader… it saw the port (still COM5) and flashed the Ardiono with the hex file.
Opened Arduino IDE and set it for Grbl com per Wiki notes. No error this time with IDE. But I don’t know what to do with the IDE.
So back to plan about calling it a night.

If you loaded the HEX file with Xloader, IDE isn’t needed anymore. Just reset the Arduino and then try Easel.

The Arduino IDE is just used to load GRBL which is what Xloader is doing.

I think.

The magnifying glass in the upper right hand corner of the IDE is the serial monitor. Click on it and it should open a terminal window which after a brief pause should show the version number of grbl.

In the line at the top enter “$$” without the quotes and carriage return - grbl should show its paramters.

They will look something like this:

$0=10 (step pulse, usec)
$1=255 (step idle delay, msec)
$2=0 (step port invert mask:00000000)
$3=3 (dir port invert mask:00000011)
$4=0 (step enable invert, bool)
$5=0 (limit pins invert, bool)
$6=0 (probe pin invert, bool)
$10=3 (status report mask:00000011)
$11=0.020 (junction deviation, mm)
$12=0.002 (arc tolerance, mm)
$13=0 (report inches, bool)
$20=0 (soft limits, bool)
$21=0 (hard limits, bool)
$22=0 (homing cycle, bool)
$23=3 (homing dir invert mask:00000011)
$24=25.000 (homing feed, mm/min)
$25=750.000 (homing seek, mm/min)
$26=250 (homing debounce, msec)
$27=1.000 (homing pull-off, mm)
$30=255. (rpm max)
$31=0. (rpm min)
$100=40.000 (x, step/mm)
$101=40.000 (y, step/mm)
$102=188.947 (z, step/mm)
$110=8000.000 (x max rate, mm/min)
$111=8000.000 (y max rate, mm/min)
$112=500.000 (z max rate, mm/min)
$120=500.000 (x accel, mm/sec^2)
$121=500.000 (y accel, mm/sec^2)
$122=50.000 (z accel, mm/sec^2)
$130=740.000 (x max travel, mm)
$131=790.000 (y max travel, mm)
$132=100.000 (z max travel, mm)