Did I Fry Either my Gshield or Arduino? {Resolved by buying a new computer!}

Gshield back on. Lights all green now. (gasp!)
Ran IDE… $$ check worked.

Now to try configuration with Easel… Crossing fingers.

Still cannot configure machine in Easel. Lights on Gshield are solid green but will blink out in unison then back on once every second. Easel does not find the machine on COM5.
Easel driver?

As Steve says you can only access the Arduino with one program at a time. Did you shutdown the Arduino IDE? Also, check and make sure that the Arduino is still on COM5.

yes to both of those. IDE is closed (easel is closed now too) and computer sees Arduino on COM5.

Post the $$ output here.

Ok, the core of your Arduino is working fine.

Uninstall Easel Local on your machine by using the Control Panel Programs and Features.

Restart Windows.

Go back into Easel and re-install Easel Local and see if that helps.

I’ll start with that in the morning. I’m pulling the plug now. Literally.
Thank you for all your help.
Will post in the morning with ongoing status.

1 Like

Ok, night.

I should be flashed with GRBL 0.9j now and will uninstall and reinstall Easel in the morning and let you all know. Oh, wait. Maybe I’m on the Larry hex file now. I can’t even think straight.

Word on the street is that Larry hex is what all the cool kids are using.


Based on your $$ output, you are on Larry’s 1.0c version. If you use this link: http://bit.ly/1I8Ey4S and you need to revert, that file will get you back to 0.9j that works (I tested it). You may have to right click and choose “Save As”.

Latest and greatest - going out to buy a new laptop. The fact that the one I have is a complete dog is not helping my stress levels any. I literally waited 20 minutes and still couldn’t get into Add/Remove Programs…

Looking at some cheap open box buys that don’t need to handle anything other than Easel…

1 Like

New machine. (Asus open box - works like a charm compared to the old computer so already that has me happy).

Set up the machine, installed Arduino drivers, plugged in USB (saw Arduino right away) installed Easel 2.7.1 (still running Larry’s GRBL) checked everything in Arduino IDE, set the port and baud…

Went into Easel to machine setup and…it just hung. So I figured “what the hell” and I pushed the carve button and low and behold…IT WORKED. Now, of course, I’ve got other mechanical issues (which I was just closing in when the computer stopped talking to the machine) and I think I have either my v-wheels or my belts too tight on the x-axis because it won’t move in either direction (Y and Z okay) but that’s something I think I can deal with.

A big thank you to everyone who helped. Some questions…

1.) When / how often do I need to worry about flashing GRBL onto the Arduino?
2.) Same for Arduino driver updates - how often should I be thinking about looking at those updates? Or is a working x-carve a happy x-carve no matter the driver age?

I have to say that I have learned a lot about the electronics portion. Now back to the mechanical tuning…

1 Like

There’s always another question.

I am not getting the option for homing when I first start up Easel and start the first carve, nor is there an option for homing under the Machine drop down…

I think it’s only enabled via the Machine setup routine which you may want to run just to set the defaults for the Xcarve.

You should run the machine setup procedure in Easel to get your machine working the way you want it to. There are settings in grbl that allow you to choose the various options. The easiest way to get them set for your machine is to run machine setup in Easel.

If you want to do it ala carte, you can set the parameters directly into grbl.

As far as which version of grbl to run that’s a personal preference item, at this point, 0.9j, 1.0c, or my version will all give you good results as long as you get a good version of the .hex file.

Interestingly enough, I cannot run the Machine setup. It just sits there, thinking. I’d rather be able to set it in Easel (although I’ve learned a lot in the past 48 hours). Perhaps I haven’t let it sit and think long enough? I can be pretty impatient, but I don’t remember it ever taking very long, even on my old, crappy laptop.

So, there’s STILL something up. Ugh…

The machine setup process as I have run it doesn’t take very long. We can bypass that process and do it manually if that’s the only issue remaining. Does Easel seem to work when you do normal things?

All’s I’ve done with Easel so far is to go in to the first carve screen in order to move my carriages back and forth to fine-tune the tightness on my v-wheels and that seems to work fine.

I’m up to doing it manually, but it’s still a bummer that I can’t get that last 5% working right. At this point, beggers can’t be choosers, though.

Throw it at me, Larry! Let’s do this! :slight_smile:

I just did the machine setup again with Easel. It took me about 30 seconds start to finish.

Which machine do you have (500,500) (750,750)(1000,1000)?

Do the motors move in the correct direction when you press the buttons in machine setup?

Do you want to use homing?

Do you have a probe for probing the Z axis?

ACME rod or M8 threaded?

Do you have the new X makerslide or the original?