Did I fry my adruino card?

I moved machine and apparantly the red stepper motor wire came loose. I tried to jog X and it shuddered but wouldn’t jog. So I found wire had popped out put it back. Now I try to jog and any axis will give one little pulse then nothing no movement. I have also noticed that the green lights go out on adruino on Y and Z, X stays lit. I have restarted many times checked wires and always same result. Is my adruino card shorted out or something?

Check once again to make sure that your stepper motor wires are connected properly to the gShield. No loose screws and all strands of wire are in the correct place. No shorts between terminals, even one strand can be bad.

Re-seat the gShield on the Arduino to make sure that it is in full contact with the Arduino. Sometimes they can work loose.

The green LEDs will turn on and off depending on which direction the current is flowing through the windings so your observations may be normal operation.

I checked wiring re did a couple connections just to make sure, re seated G-shield to adruino no change. jog any axis I get one small pulse/movement then Y and Z green light go out X stays on, same result every time. I called tech support and thinking that G-shield card went bad they sent me out a new one. But unfortunately i put it in got all green lights and blue light. But as soon as i try to jog machine I get same results as stated above. Any Ideas?

Have you tried re-loading grbl? Which program are you using to jog?

ok I am using easel, I just re-loaded grbl. tried it and had all green lights one pulse then Y and Z went out no movement. man this is frustrating. i have been using this machine no problems for a couple of weeks, finally got my new table, built dust control in. Now its dead useless. Any other ideas. replace adruino card?

Yes. At this point it seems the best thing to try. Since the new gShield is acting almost the same as the original the ony thing that is still common is the Arduino.

When the motor wire came loose it’s possible that it touched something on the Arduino and fried it with 24 volts.

Due to the frustration factor, I would get a new Arduino, they don’t cost that much.