Did I fry my GShield?

Last night I was wiring up my J Tech laser engraver when I accidentally swapped the PWM wiring - so, at one point I was feeding 24V worth of “go” into the GShield, through the black/yellow PWM wires (instead of reading “go” through those same wires).

Now, my Uno looks fine in Windows and UGS still sees the COM port in Linux, but neither will talk to the X-Carve enough to get it to respond. I get the below message from UGS (I’ve tried updating to the most-recent nightly build…same error) when I try to click the $X unlock command. FWIW, UGS does not show the red LOCKED indicator anymore, as it did before this event occurred. The X-Carve also doesn’t make the little initialization sounds that it used to when making the connection through UGS.

Trying to do the Easel machine setup, via Chrome within Windows, it just spins and spins.

Any opinions of what to test (or buy!) next would be much appreciated. I’m thinking a new GShield is the first place to start…:frowning:


Most likely place to start is the Arduino. Basically the spindle control is a pass through on the gShield. The wiring through the connector is more robust than the Arduino I/O port so I think you probably fried that port and maybe some other aspects of the Arduino.

Look up the threads to reflash our Arduino first. It might take. I certainly have fried my share of Arduino’s in the past. Any Arduino Uno R3 clone should work. It is probably not your gShield.

Thanks guys. I called support asking for advice in standing up both a new Uno and gShield, and they’re sending me a new gShield. Their thinking is that if Windows and Linux can see the Uno, that the problem is probably the gShield. They advised me on the reflash approach, too, so I think I’m going to stop by Microcenter this evening to pick up an Uno clone and try that first while I’m waiting on the new gShield.

Thanks again for your advice!

Are you a Prime member? You can get this tomorrow for less: http://www.amazon.com/Board-Atmega328p-Atmega16u2-Cable-Arduino/dp/B00OBSD202/ref=sr_1_5?ie=UTF8&qid=1443552533&sr=8-5&keywords=uno+r3&refinements=p_85%3A2470955011

WAIT - Scratch that. They are on sale at Microcenter! The Inland r3 version is only $5.99 at Microcenter! Plus, I love Microcenter so it is good to support them. I go to the Minnesota location.

Yeah I happened to be in Microcenter over the weekend and noticed those $6 boards…still don’t know why I didn’t just grab a handful while I was there.

I love Microcenter, too, but they’ve always been inventory-management-challenged, IMO. The one here in Denver is especially horrible in their DIY section: needle, meet haystack.

There’s an awesome brick-and-mortar franchise opportunity out there for this maker revolution. I’d be at that place every weekend if it existed (you know, because I just can’t wait on Amazon Prime!). Unfortunately I don’t have the energy or capital backing to make that happen…

I would buy a couple too… problem is, they are HUGE compared to the other Arduino formats, so they are hard to actually use in projects. I made a spindle tachometer out of one of the big ones because I wanted to use them up. NOw I regret it because it looks like a 1990 cell phone stuck to the front of my router.

so your collective early diagnoseez are looking to be the front-runners. can’t even upload an eprom-wiping sketch to the existing Uno at this point. A fresh Uno is clearly in order before anything else is attempted.

Nice! Now you will have a back-up G-Shield and a couple of $6 backup Arduinos.

yup, a simple Uno swap fixed the problem. I’d share my laser engraving examples from tonight but I wouldn’t be able to pick the best one!

Thanks guys - really (REALLY) helpful in getting me back into production (production being a relative term!).

1 Like

Glad you’re back in business.

Oh, post them all, we’ll vote! :grinning: