Did i just fry my audrino? Changed wires now won't connect

I had my 1000x1000 X carve up and running just fine… Was going through the motions and getting everything set up. During my first carve i realized when i hit “raise my router” the router would move forward and not up… No big deal right?
I unplug the power supply from the wall (forgot to unplug it from the USB) i swap out the wires and try to start the machine up again. This time i cant connect to easel. Open the case back up and find the Z ground out of the block and touching the case. I plug it back into the block and still not connecting. I remove all the wires and still no connection. Put the wires back to pre-screwup position and still no connection.

I find some information to re-flash grbl on my audrino and go through those steps. About halfway through i hit a roadblock. When trying to run eprom_clear i end up getting an error of “can’t open device . com5 the system cannot find the file specified.” I unplug the gShield and try again… Nothing. I switch USB ports… Nothing. Check to make sure my com port is right… Nothing. Tried uninstalling drivers and reinstalling them… Nothing.

Side note: when everything is plugged in i get a green light on the audrino and 1 on the gShield with 3 blues next to the axis blocks.

Help i am at a loss. It was all working fine then now its not.

edit: forgot to add i have restarted also.

Hmm. That is odd. Did you buy your Arduino through Inventables? Inexplicable communication losses are somet I mes attributable to using a bricked Chinese counterfeit Arduino.

Got everything from inventables except for the dewalt 611

I took a break to play my dogs and came back and now it seems to be working. Maybe my dogs felt left out so they sabotaged it…

1 Like

I think mine does that as well :slight_smile:

I have have had an ongoing issue like this, it happens mostly when the computer stays on for along time. If I shut down and log back in it will reconnect. I talked to Sam at inventables and she mentioned to put Google Chrome on the computer but it didn’t make a difference, so I gave up trying.

Just an update. Turns out my issue was windows 7. I downgraded to version 2.4 of easel and now everything works just fine.

I’m wondering if the resolution to the issue was due to reinstalling the driver than actually reverting to an earlier version?