Inventables Community Forum

Direct Drive Upgraded X-Carve not moving X/Y properly

I have been having the same issue, but with one additional problem. I have adjusted all the Gcode settings according to the upgrade manufacture’s guidance, only to have Easel change some of the settings back to default. Specifically, $102, $130, $131 continue to revert back to default while all my other changes stay as I changed them. My machine will properly go to the home position, but everything is locked from that point on. Have you found a solution to your problem? Any tips you may have would be greatly appreciated.

Im guessing Easel does this because its specific to Xcarve. So it assumes you have an X carve with an acme lead screw yada yada yada, then sets grbl settings to that machine. My suggestion is find a third party program to use.

If you download the Universal Gcode Sender, you can do the $$ in the command line tab and make your changes. Then they should be saved. I just did this today as I switched laptops and downloaded all the software to it. I like the classic version from 2015 as it is stable.

Has anyone ever had their X carve Change the Zero Position for the X axis while running? My machine somehow screwed up bad in the middle of a run and reset my X axis Zero position to about 4 inches off. This of course screwed my entire piece up which, of course, has to be done by Saturday for a wedding…fml

I know my x axis zero changed because i stopped the carve in UGS, raised the Z and sent machine to Zero. Its about 4 inches off from where I had it.

Home the machine and then send it to zero…did it really change?

More likely, you lost steps during the carve.

1 Like

I concur.

I have been waiting a while for an order placed with said aftermarket company. I reached out to him multiple times via email and social media with zero response, until I left him negative feedback on his site. He then emailed me, stating that he has recently realized that his company is “unsustainable” as it is, and that he is looking at his options. It’s further unnerving to me that you bought all that stuff and you have to come here for support. As always, this community rocks !!! Good luck Jeremy.

After I noticed it was way off I stopped the run. I had machine return to zero and it was off by about 4 inches. (Irritated and done for the day) The following day I homed the machine and sent it to zero. Surprisingly it even got rid of my G28 coordinates which had been set using G28.1. That was surprising. Anyway it did indeed lose steps. Im not sure how it did. I ran the file again above the surface of the piece (leaving it on the board). I noticed that during the run the Y axis became uneven Y1 to Y2. This caused the machine to freak out for a moment and I stopped the run. I got them back even and did nothing further.

My question which I am going to continue to look up is this;
How can my machine lose steps on run 2 but not on run 1?

I ran a test carve for the file to ensure its visibility, it ran both files (clear out and detail run with separate bit) perfectly. (this was done on MDF.
I then put the workpiece on the table, home machine, set new zeros. ran file and it lost roughly 100m in steps.

I have flattened the piece again and have 1 more attempt before I am out $500 worth of work and have to start over on a slab of mine and then still be done by Tomorrow evening.
I am nervous as heck. Any thoughts?

Further note;
Distance between Y rails is the same front to back.
No belts used since screw drive. The screw blocks (screw runs through these on the moveable rail to allow movement) are at the same tension.

Dave,
Side note, when you get the upgrade I highly suggest removing and reinstalling with some form of lock-tight each screw on whatever you upgraded. I have had 2 screws fall out after only 4 carves since the upgrade.

Thank you Jeremy.

How big are your motors and did you adjust the torque down to a slower rate? I have lead screws on my other K2 cnc with 280 oz in motors and I can’t really get more than 50-60 ipm out of it. I’m just wondering if you are pushing them too hard.

1 Like

I just did the same up-grade. I 'm having the same trouble. The screws keep falling out.
Did you put lock tite on them and did it work?
Thanks

If you don’t mind would you share the g/code settings that you have now?
Thanks
Gerald

I have used ACME screws myselv and I used Loctite on all set screw and also in the coupler openings for the ACME screws and stepper shaft. Loctite is a must IMHO for confident carving.

Was the upgrade completed and all the problems resolved? I ask because I recently did successfully implement the TBDcnc upgrades. I am quiet please with the results.