Disabling motors when done carving?

Hi all,

I’m trying to disable the motors (specifically the high pitch noise, along with wasted current) after milling with Carvey. Is there some gcode I can send to disable the motors?

I’ve read https://github.com/grbl/grbl/wiki/Configuring-Grbl-v0.9 and it appears that setting $1 (step idle delay) to some number below 255 should do it (I’ve tried 0, 10, 100 and 250), but I still hear the motor. I suspect there is a way because when first turning Carvey on, the motors are not energized and are only energized after beginning an operation.

I’ve also tried the following commands which have not stopped the high pitched sound: G4 (dwell), M0 (stop temporarily regardless of switch), M1 (stop temporarily), M2 (end program), M5 (stop spindle turning), and M30 (program end).


$1=0 should definitely release the stepper hold

I was experimenting with this: After setting the step idle delay to 0, send it a movement command. Then the motors will be disabled.
I am not sure if it was just my setup or a GRBL bug/feature/behavior.