Draw in SketchUp and move to Easel

While the subject has come up a few times, I have yet to find a clear step by step process to accomplish this. I have understood that 3-dimensional designs don’t transfer well, but having gotten as far as having the FlightOfIdeas SVG extension into SketchUp 2016, I still cannot even get a simple one-dimensional drawing of a square or circle converted into an .svg file that is correctly imported into Easel. Can anyone help, or am I the only woodworker here that uses SketchUp ?

I have recently got a 3d model from Grabcad. I converted a laborious way but worked, I used widows screen shot and copied and cropped in paint then saved the file as png and imported in inkscape then traced it and corrected it. the final outcome was not bad. hope this is helpful.

Thank you, Chandra. I was hoping that, with so many wood workers using both SketchUp and Easel, someone would have figured out a more “automated” process, specially since there is a .SVG export extension available for SketchUp. But, any way is better than no way, so if nothing better shows up, I will certainly give your printscreen/Paint/Inkscape/Easel process a try.

In SketchUp select only the faces you want to export and the use the FlightOfIdeas SVG extension to export it

read this

GlennMDutcher: tried that, but must be doing something wrong. When I draw a simple square or circle in SketchUp (and it can’t get any simpler than that), select that 2-dimensional face and export it as a .SVG, it does give me a .SVG file, but importing that file into Easel, I get “subject too large” or somesuch message (even though the size of the object in SketchUp is only 2 or 3 inches big), and get an otherwise blank page. Any ideas?

When you export only the “Export outlines of faces” should be checked

See if that helps

I recently released a video on this very subject, and apparently forgot to put it into the maintenance video thread. Will do right after this.

The short version is that after making the SVG, I have to open it in Makercam.com and save it again as an SVG since Easel doesn’t seem to like the SketchUp flavor of SVG. Don’t know why, but it works.


Glenn: Sorry for the long delay. That did help, but I still find the whole process more complicated than I would like… Will continue to look for something better. Thanks for the help, though.


Robert: Sorry for the long delay. I did watch your video and it did make things clearer. Still, as I mentioned to Glenn, I find the whole process very cumbersome; will continue to look for something better (I hope). Thanks for the help, though.


I know I’m a bit late on this topic but I just tried to find the Flight of Ideas plugin and cant find it. Did it go away and if so is there another one? Thanks for your time and info.

David: can’t really tell you. I have long since given up on using SketchUp for anything that needs to go to X-Carve, it was too much of a hassle and I never did get anything useful.
From what I recall, Flight of Ideas was one of the options listed under the Extensions drop down menu. I still cannot believe that, as useful as SketchUp is to woodworkers, there are so few, if any, on this blog that use it as a CAD program.

Thanks for the info. Yeah I started in Sketchup not long ago. Haven’t been doing this very long. Seems a lot of people are switching to Fusion 360 but my brain may not be large enough to manage that one. I also have vcarve pro. What would you suggest?

I can share my problem and workaround. I am using SolidWorks CAD-program (sorry expensive). I make a 2D sketch and save it as .dxf. Import it in Inkscape (free program) Then direct save it as a .svg file. Import the .svg file into Easel and you have it always to the left in the coordinat system, even if the sketch was long from origo. BUT why can I not get “Inside” or “Outline”. It is always "On Path"