Drawing in Autocad -> Illuistrator -> Easel- Cannot put tabs on object

Ok, So I have a file that I have drawn in Autocad that is approx. 16" long (widest part) and I export it as an .eps file to edit it in Adobe Illuistrator.
Autocad DWG blocker333.dwg (95.8 KB)
EPS File - blocker3.eps (2.8 KB)

Ok, so I hit expand on the object and then save it as a SVG file(wouldn’t let me upload it so it’s in a zip - (blocker3svg.zip (1.4 KB))

This is what it looks like on the Artboard after I hit the Expand -



The Black space is the finished product that I would like cut out - It needs tabs as I am cutting out of Lexan so even taped down, it still likes to pull up and move. Yes, I could do this in Fusion 360 but I would like to figure this out as it is easier to do in Autocad and Easel will auto generate the tabs…

Then when I import it into Easel it looks like this-

The Image describes what I need to happen, however the size has changed too.
Any input on how to color it in Illustrator or how make separate objects and line them up in easel to be precise? Also how to maintain the correct size between the conversions?

Thanks!
Brent Sancken

Can you share your project, or at least a copy of your project as it currently is.
This way others can try experiment in Easel.
To Copy: Easel Menu -> File -> Make a Copy
To Share: Easel Menu -> File -> Share

Paste the url into your post.

So here it is imported - I didn’t play with the size or position, just the tabs. I need tabs on the inner cuts too but it doesn’t seem to treat those as “separate” cuts.


Thanks
Brent S.

I opened your DWG and found a dobble line (curve) at the very top .(tip) This needs to be deleted.

I think this is your desired end result. I’m not 100% sure to exactly what’s happening as I don’t have anything to vector edit on this PC but I’ll try to look more tonight.

http://easel.inventables.com/projects/Z5hs7ih9gN7HZxLX2VbSLQ#

I reworked it in Inkscape, see if this works for ya:

Blocker-Easel file

Just resize it using the shape tool

@BrentSancken, the blocker3svg.zip you attached works fine when I import it into Easel and convert everything to full-depth strokes. But the project you linked is different—the SVG has 5 separate objects whereas the shared project has one object containing 5 holes.

My guess is that the version of the SVG you imported for that project used the evenodd fill rule, which doesn’t work in Easel. If that was the case, moving the holes to their own objects would solve it. Another solution would be to use the nonzero rule and reverse the point order of the holes (or of the outer shape).

Ok, so it looks like I might have mixed up a svg file with one I was experimenting with… So I just went through the chain again and created clean copies and I still can’t put tabs on the inner parts…

Dwg - blocker3.dwg (96.1 KB)
EPS - blocker4.eps (2.8 KB)
EPS file after expand command - blocker4expand.eps (251.5 KB)
SVG file used in project (again, this time on chrome/mac couldn’t upload the svg- says corrupted) - blocker4expand.svg.zip (1.6 KB)
Easel Project - http://easel.inventables.com/projects/i9ijC7x4QZzrSQAGU06k3A#

So it sounds like I should go Autocad -> Inkscape -> to SVG? It sounds to be easier…

Also when you say “convert to full depth” Is that just setting the cutting depth to all the way through? or am I missing something else?

Thank!
Brent Sancken

OK I tried your new SVG file, there was no line weight or style set, was grouped into one object.

See it here

Easel blocker project

Yep, that’s what I meant.

In Illustrator, make sure you right-click your object, ungroup it, right click it again, and click “release compound paths”

What you have currently is like a donut. Easel is treating it as one shape that has holes in it. What you want are several shapes together that have no relationship to each other.