Dual Y axis will only move in one direction

So I’ve got a bit of a Frankenstein machine with a lot of original Xcarve parts, but beefier motors, GRBL Arduino, those individual TB6600 motor drivers to break out that task, and dual Y motors.

I’ve haven’t used the machine in about a year and a half while we moved and got situated. I recently set everything up, but I’m experiencing something strange…the Y motors will only move the gantry away from the user.

The X is running fine, the Z is running fine, but when I jog the Y axis, forward and reverse just get me reverse.

Any clues on this? This machine worked fine when I packed it up. Worked very well actually. Sorry if this is dumb question, I’m just getting back in to this and lost a lot of information. (Meaning forgot)

Do both of the Y´s move the same direction, seperately?

A stepper havve 4 wires, if one of them is faulty the stepper will move normally, but directional control is lost.

They are both engaging and not fighting each other…so thats good. They move away from me together…just not toward me.

I’ll check out all the wiring next!

I found it…when I rewired the motors, I knocked out one of the signal wires from the shield to the Y motor controllers. Woops

1 Like

Glad you got it working!

Yeah! Thank heavens for this forum. I knew I’d find the answer.

I’m really excited to be getting back into my CNC.

1 Like