DXF File Import Question

i have been fighting with easel. i get an autocad dxf and import in to easel. the size is small, nothing machines in correct position. this is not the easy to use software it claims to be. i do not want to waste my time and money on having to import a plan, machine it on scrap material to make sure it is correct, then turn around and machine on what i want to use. continuing to mess with code headers and what not. their has to be a better program than this.

What are you trying to do? Easel doesn’t support DXF so that might be the issue. Do you know how to create gcode?

i convert the dxf files to svg. but when i convert them a object that is supposed to be around 1.5 in wide x 7.5 in wide ends up being only 3 inches long.

Happens to me all the time, the fix is to select the object and resize it using the shape tool, just tell easel what size you you want it to be

thank you on the resize tip. now have issue where i can not change the outline mill. it says that i have to add the tool paths for the file.

Sounds like you have an open path, that can be a problem with DFX files. In order for Easel to create an out line the path must be closed.

The item on top is a closed path
The item on the bottom is a DXF of the same thing but is tiled in to 6 pieces

If you upload the SVG here maybe I can fix it for you

lol. i am not sure you want to do that

ok, I’m not sure how you fix that in Fusion 360, maybe someone else can help

how else can you fix it?

now i cant even open up my file in easel. please tell me if their is a more reliable program to run the shapeoko 2

Hi Eric

If Easel is not quite right for you at the moment then you could try VCarve Pro. I often export dxf from Draftsight (used to do it with AutoCAD too) into VCarve Pro, that then produces the gcode that I need to drive the X-Carve. It works a treat.

My X-Carve is running now with some toolpaths created in VCarve Pro. The free clipart and multitude of tutorials and free projects are really useful.


@ericrobinson If you are using Fusion 360 there is no reason to import your DXF into Easel. You can export g-code and import that into Easel.

Go to “Import” and select “G-code”. You’ll need to install the Easel post processor for Fusion 360 one time and from then on you are good to go.

1 Like

ok i figured that out. next problem is that half of my tool path is off the work space. i move it where it should be at in fusion 360 and import the gcode again, but it is still in same place in easel.

vcarve is no better than easel. if i open up a file that i know it is the size i need it to be, i should not have to resize it. an object that should be just over 12 inches, is 270 in vcarve.

composite.dxf (318.2 KB is someone could possable do the tool paths for me so i can see what i am doing wrong. no matter what program i try nothing works out.

From left to right, the first piece is from y=0, 11.5 inches tall.
Since it does not start at 0, the piece is actually 10.63 inches tall.

To generate toolpaths, you will need to join the vectors, it is currently made up of lots of separate pieces to form the outline of the parts.

Here is the same file with all closed vectors.
Composite - Closed vectors.dxf (103.6 KB)

so how do you close the vectors?

What software did you use, vcarve? Select the vectors, right click and join.

You can tell which ones are open by clicking the edit menu option and select all open vectors, that will show you which ones need to be closed.