DXF import not working?

Dxf import is not importing correctly… only getting 1/2 of the file? simple OD-ID ring… only getting the outside line sometimes… and others only the inside… have tried with newly generated dxf and existing that I created projects from… on 2 different computers with 2 different browsers…same results…

I was experiencing an issue the other day where the DXF would import and show up correctly on the preview window, but would fail to actually import into the work-piece. I have not checked it since though, so I cannot say whether it is still occurring. If you are experiencing a similar issue then maybe a bug has crept into the app somewhere…


Brandon Parker

Which is really a problem… I use the machine daily…it generally runs 2 hours a day if not more… simple parts… Worked last week just fine… today tried to import dxf to do an estimate for a customer (machine time) and couldn’t do one… had to guess… Also just got a rush job in for another customer, and I’m dead in the water. ZERO response from customer service. NOT GOOD. :frowning: This is exactly why a web based app is a bad idea.

I just checked, the app worked for me today, but the design was MASSIVE and everything was so far off screen that I couldn’t see it. Selecting everything by selecting the outline, and then “Select by matching depth” allowed me to scale everything correctly.


Brandon Parker

sounds like they have some MASSIVE issues… lol I can’t scale like that… these have to be exact. ±.025

Well, if the DXF will actually import then just select everything and then lock the Width/Height Ratio and scale the entire thing to the correct value for one of them. The ratio should should cause everything to scale accordingly.


Brandon Parker

I just went back and checked one of the imports I tried to do (autosaved) thought it was maybe as you had suggested that it just imported way out of scale… nope… well it is out of scale, but only 1 of 2 concentric circles imported, so there is something wonky happening… at this point, I’m about to buy another product… yes, it’s going to cost about $8K, but at least I’ll get support from the mfr (not a peep from tech support on this, I called and of course they do not answer) and won’t have to deal with web base software…

Update… the dxf shows up in the “preview” window incorrectly as well, but I found what the exact problem is. for whatever reason it is taking both circles and making them exactly the same size. so, if after I import I select the shape and delete, I’m left with another shape beneath it exactly the same size. This is definitely an Easel glitch problem. I can import into meshcam and vcarve just fine.

2nd update… I tried with a few other dxf files…that are not just circles… it seems it it duplicating lines i.e. one exact shape on top of another, when there is only 1 in the actual drawing…

Hi @DavidMCook and @BrandonR_Parker,

Thanks for giving us a heads-up about unexpected behavior importing DXFs into Easel. We’re taking a look. You willing to DM me the files you’re having trouble with? Will help us diagnose.

Easel Product Manager

the files don’t seem to be the issue… I can replicate with multiple files… on different machines… with different browsers… I even tried converting to svg… the shape was correct, but completely the wrong size… instead of 4.5" OD, it’s over 7" 4-5 X 1-063.DXF (27.8 KB)
4-5 X 1-063_Model

Also… try this…
This is a project I made

this is the dxf used to create

ratchet 9-25 x 4 waffle.DXF (17.0 KB)

When I try to upload the DXF today, the ID circle is missing… even in the preview…

and just for kicks, I downloaded fusion360… created a sketch… exported dxf… tried to import to easel… same results.

Hi @DavidMCook,
We have made some changes to the app which should alleviate issues with shapes being imported.

I have tried importing both files you attached. The first one shows OD as 4.625" in both AutoCAD and Easel. Second one imports with both ID (3.875" diameter) and OD (9.375" diameter) circles present. Here is the project with both files imported https://easel.inventables.com/projects/H5JZ9if0LwQ4jeDKZag41A

Hope this solves your issues, thanks for reaching out!

Just tried… working now…

Curious as to what the issue was? Why it happened? what steps are being taken to assure your customers it does not repeat?


Another option to help with issues could be to provide the Height & Width as the design is imported on the app window. You could then provide the user with two options for scaling: by width/height (changing one changes the other according to their ratio) or by percentage.

The issue I have apparently stems from a custom scaling “thing” that DesignSpark PCB is doing (not the first time I have encountered this with their files); everything is scaled up by a factor of 1000. Simply selecting everything in my design, locking the Height/Width Ratio and changing the Width according to what it is supposed to be resized everything to the correct dimensions. That’s why I say that if the sizing information were on the app window and changes could be made there it would be GREAT!


Brandon Parker

Hi @DavidMCook,
The issue was due to precision and numerical errors, which had unintended consequences downstream.

We are working on better support on all Easel fronts. If you experience an issue you can reach out to our excellent Customer Success team & use the forum. We are actively monitoring the community and try to help where we can.

@BrandonR_Parker That is an interesting idea. Would you happen to have a DXF from DesignSpark PCB software you could attach here so I can do some testing?

Well, I did call… and after sitting on hold for about 5 minutes I left a message with my callback information… no one called. So excellent is not something I would necessarily use to describe your customer support.

Yeah, Computer Science is my game, and I always try to think of ways to make the user’s experience better when I can.

Here is the file I was talking about. The width of the board should be 0.95" and the height should be 2.075".
Test.dxf (3.9 KB)


Brandon Parker

1 Like

Five minutes is nothing man… Maybe you caught Customer Service at a busy time. Considering the state of the world these days people and companies deserve a little slack sometimes.


Brandon Parker