Easel 0.3.7 don't work for me

I spent some time without using my X-CARVE. Today, when I tried to use it, a message appeared saying that there was an easel update to be made. As I always do, I downloaded and installed. I did this on a PC and on a MAC. Both computers had the same problem. They Are asking me to install the same firmware and do not allow me to continue the carving operation. Could someone help me with this? Thanks in advance for any help.

What windows system are you using? I’m using vista and the newest didn’t work for me. I’m still new at this though.

I’m using a MAC with macOS Sierra 10.12.5 and PC with Windows XP.

1 Like

I carved without updating the firmware, it’s not a requirement.

1 Like

I had the exact same thing happen to me. 0.3.7 New download. I installed it (on chrome, on my Macbook). But every time I’d go to carve, I’d get the error message saying that I needed to download the driver again. I tried using it on Safari (browser) instead of chrome, and it was working.

I have Adblock running on Chrome.
I disabled Adblock (or whitelisted the inventables domain, rather).
Now it’s working fine.

I wonder if you’ve got something similar going on.

1 Like

Hi Joshua. My case was fixed by John Hayes using a software called teamviewer. Thanks for your support. Have a nice weekend.

im having this same problem now on my mac. Ive installed the new easel driver a cpl times and its still popping up that i need to update before going further in the carve setup. i was really hoping to get a project knocked out this weekend but i may have to wait to get them on team viewer this week.

did they tell you what the issue was or how they fixed it? im running g-shield/arduino

Ditto. When I whitelisted the domain in my adblocker it worked. Thanks for the tip!

1 Like

I was having the same issues using windows 10. Carve button would be blue and when I hit it, it would say I needed to download the easel driver. I delted and reinstalled the driver several times with zero luck. Found this post and read the comment then went in and ok’d the site through adblocker and BAM! Intantly turnt green and ready to CARVE!!!