Easel and Easel Pro is now buggy and unreliable

It used to work great until they “upgraded” it.

I’m certainly not paying to use something like Easel that won’t work at all…

Who has a great walkthrough for using something else?

I hear a lot of folks are using Fusion 360 and UGS?

I used VCarve for CAD and PicSender to send the GCode. Great combination. It works great with the Triquetra P3 Auto Zero Touch Plate.


check out carbide create and UGS for a sender.

Easel and Easel Pro are working for me.

What kinds of bugs or unreliable behavior are you seeing?

There have been things on and off since Pro started. Just yesterday I had several outside cutouts cut before interior pockets. Also have intermittent problems moving the preview image around the window.

Hi Chris,

Easel Pro does not have any effect on the tool path ordering or the 3D preview. Please PM me the URLs of projects that had tool path ordering issues and we can take a look at it.

I invited you to a pm to David Altenburg with the URLs

easel crashes on clicking the detailed preview, simulate, or carve.

Thanks! I did look at picsender. Do you think it is as good or better than UGS?

Is it stable from things like random software changes at really inconvenient times?

I have had issues with Easel and Easel Pro running extremely slow since the update. Have there been changes in system requirements? I actually ran a test where i carved a project with Easel Pro and then generated the g-code then carved it with UGS. UGS was ~ 9 minutes faster. I do understand that Easel is dependent on an internet connection but the times were much closer to UGS before the upgrade. At least that is the way it appears form my experience.

I normally use a chrome book to do my design and then go to the shop to carve. I have noticed that the time it takes just to open a project in Easel is extremely slower both in my shop and on my chrome book. I was thinking it might be my internet connection so i tried it on my computer at work ( which has a T1 line) and it still took almost a full minute for Easel to open.

I have also had Easel just stop in the middle of a project and tell me it is finished. Before you ask i have a hard line for my internet connection. This is part of why I feel the PRO title is not fitting. If i were running a business and i had an one hour carve stop after less than five minutes, telling me the project is complete while the status bar is still showing 10% I would be more than a little upset. This has happened with Easel in the past but it seems to be more frequent since i started using PRO. This kind of instability is NOT what one would expect from “PRO” software.

I found PicSender to be an excellent piece of software. The only errors I usually got was when it was trying to recover from errors I caused. A lot of folks seem to be happy with UGS. PicSender worked great with Charlie’s Triquetra Touch Plate. You download PicSender, so once it’s working, it’s working. No cloud connection. You own it, you control it.


@JeffHolmes Easel is not dependent on an internet connection for sending g-code. That process happens locally.

These don’t sound like internet related issues. If I had to guess it is more processor related than internet but I don’t know for sure. Would you be able to PM me a link to the file so we can test it?

In my case, the same exact project worked perfectly until after the ‘update’ was done.

As far as a processor issue, wouldn’t a Intel® Core™ i7-7700K with 12gb of ram be enough? And yes, I have a decent graphics processor as well. That hardware did not change - just the update on easel did.

I will try to find find it in my log book. I have had this happen on different files. It does sorta make sense about the processor but why would I get the popup asking if my carving was good while the status is at 10%
With that in said I could definitely see it being my processor. I just have convince my wife I need an upgrade.

I want to be clear, I do really like Easel PRO and look forward to what I can do with it.

Hi Jeff Holmes,

If you ever have a problem where Easel stops before the job is done, please click “No” when Easel asks if everything turned out all right, then click to “get help from Inventables” and submit a note describing what happened. This will capture a lot of debugging information including possible grbl errors that might have happened, which we can use to troubleshoot the problem.


There wasn’t one singular update. We update Easel all the time, sometimes multiple times per day, sometimes weekly.

I don’t know if we introduced a performance issue or if something is impacting that file. It’s certainly something we can look into. If you PM me the link to the file I can send it to software engineering for analysis.

1 Like

Just a reference point, I’m currently carving a project that I have carved many times before, its running without issue. its over 60% done and my controller runs the most current updates and I’m using Easel Pro.
Could it be be issues with USB communication? possibly a connection is not socketed in as tight as it could be

I already did.