Easel Becoming Unresponsive

I had a project that was saved as a .DXF File. I opened it in Adobe illustrator, and then saved it as an .SVG file. When I import the file into easel, I get a message from the browser saying that Chrome has become unresponsive. Anyone else having this problem?

Also, Im willing to put my SVG file here to see if others are able to open it correctly. How do I do that?

Hi @KirkWasham there might be some corruption in the file.

Can you close the browser and re open it. The first try to add a shape from within Easel? If it becomes unresponsive then we know it’s not your file.

If that works then let’s try a different SVG that is known to work. If that works then we know it’s your file.

To upload the file there is a blue upload link when you are typing the message in the lower right hand corner.

Ok. I Tried from other computers and had the same problem. Also, I dont have an x-carve unit yet. Im debating purchasing one, but i Want to make sure it is capable of working with the cnc files that i have. I want to make guitar templates out of MDF, but Im having these problems with easel. Please let me know if you are able to get them to load correctly. Thanks, Kirk

Here is the dxf version of the above SVG file.PRScustom24cnc.dxf (512.3 KB)

Just from what i have tried in Easel, that looks way to complex for Easel to create tool paths for, i could be wrong but i have created things with much less complication and killed Easel. With that being said, I LOVE EASEL, but for my more complicated designs i still use Cut2d. But from what i remember in a previous post from Zach, they are working on this in easel, but i dont want to speak for him or inventables.

Assuming these plans are too much for easel, what software is recommended to send the project to the xcarve?

@KirkWasham thanks for posting the files. Let me show our software engineering team tomorrow.

They have been working on rebuilding the geometry engine.

The issue you are experiencing with the complexity of processing the file. Right now it is trying to do the whole thing synchronously but they are working on making it more asynchronous so Easel stays responsive but it keeps processing in the background.

Do you know what kind of processor and graphics card you have on the computer?


Definitely a problem with the complexity; if you ungroup it and bring in a single part it works fine. @Zach_Kaplan I don’t think it’s a processor or graphics card issue on the end user as i’m using a Intel i7 with Dual Nvidia GeForce GTX 770M SLI