Easel can't jog steppers after testing other G-Code sender

It’s my fault, I know it is, but I don’t know how to fix it. I got my X-Carve working yesterday with Easel on a Mac laptop. I had no problems whatsoever, ran a couple test passes and then shut the machines off. Later in the evening, I connected up an old PC running Linux and tried to get GrblController to connect and jog the machine. Didn’t seem to be working, so I fired up the Arduino IDE and noticed that I had to change the COM port in the Serial Monitor in order to connect. No big deal, changed it and set the baud rate and carriage return. Saw the GRBL info, gave a $$ command and saw all the params go by. Tried to move the X-Axis with a manual G-Code command (forgot exactly what) and got an error saying I hadn’t specified a feedrate. Decided I was in over my head and shut down.

Today I decided to go back to using Easel, so I could actually get something done. Fired everything up and decided to re-run the Machine Setup. Got to the part about testing the axes and nothing works now. Connected with Arduino IDE and opened Serial Monitor. Said it couldn’t find a device on the specified COM port, switched it over to the Mac COM port and verified that I could see grbl stuff in the serial monitor. Exited Arduino IDE and closed it, fired up Easel - same problem. Restarted laptop and X-Carve and tried to run setup in Easel again. No dice.

I’m pretty certain I haven’t fried anything and that I’m just not properly communicating between my laptop and the Arduino. Can someone post a set of instructions that would let me verify first in the Arduino IDE that everything is ok. Preferably with a command or two that lets me exercise the steppers. Then how to make sure that Easel has got the right settings it needs to talk to the machine.

Thanks in advance.



With the power off, manually move your machine to the middle of travel on the X and Y axis.

Power everything up and start the serial monitor.

Enter the command $X

Enter the command; G21 G91 G0 X100

this says dimensions are mm, use relative movements, rapid move X +100 mm from the current position.

If that works then try G21 G91 G0 Y100

That should be about the most simple test for motor movement you can try.

Also, post your $$ output here.

Hi Larry,

I tried the commands you suggested and got “ok” in the monitor, but no movement of the machine at all. Here is the output of my $$ command:

$0=10 (step pulse, usec)
$1=255 (step idle delay, msec)
$2=0 (step port invert mask:00000000)
$3=3 (dir port invert mask:00000011)
$4=1 (step enable invert, bool)
$5=0 (limit pins invert, bool)
$6=0 (probe pin invert, bool)
$10=3 (status report mask:00000011)
$11=0.020 (junction deviation, mm)
$12=0.002 (arc tolerance, mm)
$13=0 (report inches, bool)
$20=0 (soft limits, bool)
$21=0 (hard limits, bool)
$22=1 (homing cycle, bool)
$23=3 (homing dir invert mask:00000011)
$24=25.000 (homing feed, mm/min)
$25=750.000 (homing seek, mm/min)
$26=250 (homing debounce, msec)
$27=1.000 (homing pull-off, mm)
$100=40.000 (x, step/mm)
$101=40.000 (y, step/mm)
$102=188.976 (z, step/mm)
$110=8000.000 (x max rate, mm/min)
$111=8000.000 (y max rate, mm/min)
$112=500.000 (z max rate, mm/min)
$120=500.000 (x accel, mm/sec^2)
$121=500.000 (y accel, mm/sec^2)
$122=50.000 (z accel, mm/sec^2)
$130=790.000 (x max travel, mm)
$131=790.000 (y max travel, mm)
$132=100.000 (z max travel, mm)

Thanks for the help!


Change $4 to 0 and try again.

Thank you Larry! That totally did it! Reset the $4 parameter to “0” and everything works again. Tested the Easel setup and it worked perfectly.

I owe you.