Easel causing my machine to lock up

I’ve tried Chrome and it still locks up. Any ideas to try? I just got the email that my X-Carve is ready to be picked up and I’d like to have the software issue resolved. Any help is appreciated!!

Hi Dennis,

Could you explain in a little more detail what’s happening? Does Easel finish loading before becoming unresponsive, or does the loading screen never disappear? Is this happening with one project in particular, or are you unable to open any project or create a new one?

Thanks!

Thank you for the response! I started using Chrome as IE wouldn’t work at all. It sometimes loads all the way and then will work for maybe 30 seconds or so and then I get a black screen that will then blink between the page and black screen. Then it will either lock up or go to the blue screen that has the message about a problem with a software or other problem. Sometimes it just won’t load. I do not have any projects in there as I haven’t been able to get it to load.

Hi Dennis,

It might be an issue with the 3D rendering in Easel. Chrome has some tools to troubleshoot your system’s compatibility with WebGL and 3D graphics:

https://support.google.com/chrome/answer/1220892?hl=en

Take a look at that and see if it exposes any issues.

Jeff

hmmm i have issues with easel being really really slow at times. checking the above link says the only supported OS for chrome are win 7 and 8 and i am still using vista. i wonder if that is my problem?

Thanks for the response. I went to the google chrome support and tried the experiments to see if they would work and they did. I then went to my chrome settings and all of the Webgl settings were enabled. My machine is still locking up. Very frustrating as I now have my X-Carve but can’t get Easel to work. Any other ideas?

Hi Dennis,

I’m really sorry you’re having this trouble. As an experiment, could you try making your window very narrow and then reload Easel? This should disable the 3D side (you should see something like this screenshot on the right side after making your window larger):

If you are able to get to this point, try using Easel for a little while and let us know if it still crashes.

Cheers,
Jeff

1 Like

Thanks Jeff! I will try that tonight and report back. :blush:

yea, it seems to work with the 3d disabled. I checked and I have a Mobile Intel® 945GM Express Chipset Family adapter. Could that be the problem?

I’m not sure. It would seem that something in the stack is unable to handle the 3D computations, but I’m not sure what.

Easel could probably do a better job of degrading gracefully if the 3D side can’t be rendered properly.

?? on your last statement.

The last statement was referring to changes we could make so that Easel doesn’t crash if your system can’t render the 3D side, so that you can still use it. The 3D side makes it easier to visualize how your design will be carved, but isn’t strictly necessary. We could potentially provide some other type of 2D visualization if we can’t do 3D.

Roger that!! Thank you for the explanatioin! I’m trying to do some research as to why my machine won’t play 3D. I’m thinking the CPU is too slow and simple.

Ordering a new laptop today with intergrated graphics card, faster processor and 4G of ram. That should fix the lockup problem! :grinning:

This was what was wrong with my 3d rendering. All I saw was the 3d logo for inventables. I made a 1 min video because it was easier to show than doing a great job explaining it. https://youtu.be/RnAEg9ut3to The short version is you need to be on this page chrome://flags/ and disable the first thing which is “override software rendering list”. I hope it works.