Easel Changing GCode from Fusion 360

I’ve been experimenting with cutting .nc files generated in Fusion360, by importing them into Easel. I’ve done a lot of carves that were successful, but today I ran into two adaptive clearing strategies that went absolutely crazy.

After setting the Z probe height correctly, the bit travelled along that Z height (after a small lift), then carved the clearing strategy at least 10mm higher than the work zero I had set.

I went back to Fusion and simulated it- no problem. I watched it in Easels simulation feature, and saw the problem happen again (virtually). I exported Easels GCode to Camotics and simulated it again, and again it wasn’t the same as the toolpaths generated by Fusion.

I have attached the Fusion generated .nc file 1 From Fusion.nc (348.5 KB)

This is the link to the toolpath in Easel

And this is the .nc file exported after it went through Easel
3 Imported from Easel (307.6 KB)

Can anyone see why the toolpath is acting so differently that intended?

I just tried simulating the Fusion .nc file in Camotics too, and it has the same problem, so it’s obviously not an Easel problem. The path I see in Fusions simulation is not the same path I see in Camotics and Easel. If it’s ok I’ll leave this topic up just in case anyone has been through this also and has a solution.

Just looked at your Fusion nc on my phone. Looks like you have your zero set at the bottom of your stock. Is that how you’re setting it on your actual workpiece?


Neil, you’re right. The simulations worked within fusion, even though the work coordinate system was placed upside down. Thank you for your reply, this problem has been solved!

1 Like